[ANN] Struts Plugin V0.83beta (IDEA 5.1 EAP build #4055)

Finally found some time to fix this &$!&"/! bug preventing Struts Plugin to work in 5.1 EAP.

Future development will be focused on:
- 5.1
- as soon as Demetra EAP starts -> Demetra (IDEA 6)

Please send suggestions/feedback, especially regarding new intentions and code generation features.


Changes:

- Nested (in , ]]>): autocompletion/navigation to property
- Intention: create new sub-action in DispatchAction with user-configurable code template
- QuickFix: Create undefined form-bean in struts-config.xml
- Added some more productivity tips
- Display warning on using Struts Assistant simultaneously
- Detect Struts 1.2.8, warn on using Struts 1.2.7
- Support for Struts 1.3
- Quickfixes: do not attempt to modify read-only files
- Bugfixes

5 comments

Please send suggestions/feedback, especially
regarding new intentions and code generation
features.


Mmmmh: an intention "convert to webwork", seen the recent merge announcements? ;)

0

;)

even if it would be possible in technical terms, that would be quite a lot of work

0

o,thank u!

But I can't down struts plugin with plugins manager.

Can you help me?

0

I can down it after upgrade Idea to 4069.

0

Please sign in to leave a comment.