the library can not switch following selecting another emulator

I like install nokia sdk into wtklib of WTK 2.2, so I can use it by WTK 2.2. You know, almost all IDE support WTK2.2 if it support j2me development. In this way, I select nokia emulator as working device, and the library and emulator should switch to right ones automticly. I use Jbuilder, netbeans, both so. But for Intellij IDEA 5.0, it seems not work.

6 comments
Comment actions Permalink

Hi,
please, explain me what for do you use WTK 2.2 with Nokia. You can use plain
Nokia emulator and everything would work fine. I really don't understand why
do you need such configuration :(
Thanks.

--
Anna Kozlova
JetBrains Inc.
http://www.intellij.com
"Develop with pleasure!"


"Evans Zhang" <no_mail@jetbrains.com> wrote in message
news:16251401.1124365320960.JavaMail.itn@is.intellij.net...

I like install nokia sdk into wtklib of WTK 2.2, so I can use it by WTK

2.2. You know, almost all IDE support WTK2.2 if it support j2me development.
In this way, I select nokia emulator as working device, and the library and
emulator should switch to right ones automticly. I use Jbuilder, netbeans,
both so. But for Intellij IDEA 5.0, it seems not work.
>


0
Comment actions Permalink

Hello,
why I use wtk 2.2 with nokia emulator? because Intellij IDEA can not recognize the nokia emulator, so I had to install nokia emulator into WTK.
why I switch emulators? because I port a game to many mobile, for example, nokia s40, s60, .....all over 20 mobiles. I had to switch emulator, hope the library switch automaticlly, and build for a new mobile.

0
Comment actions Permalink

Evans Zhang wrote:

why I use wtk 2.2 with nokia emulator? because Intellij IDEA can not
recognize the nokia emulator


I'm using nokia emulators with IDEA - directly, without the WTK. Which
one are you using?

Regards,
Edwin

0
Comment actions Permalink

there are really nokia or others 's sdk can not be recognized by IDEA 5.0, but if you install them into WTK, you can use them by WTK. But when I try to config running, internla error is thrown. Is is a bug or not?

0
Comment actions Permalink

Hi,
Which one?
Thanks.

--
Anna Kozlova
JetBrains Inc.
http://www.intellij.com
"Develop with pleasure!"


"Evans Zhang" <no_mail@jetbrains.com> wrote in message
news:24449637.1124541113840.JavaMail.itn@is.intellij.net...

there are really nokia or others 's sdk can not be recognized by IDEA 5.0,

but if you install them into WTK, you can use them by WTK. But when I try to
config running, internla error is thrown. Is is a bug or not?


0
Comment actions Permalink

Evans Zhang wrote:

there are really nokia or others 's sdk can not be recognized by IDEA
5.0,


Oh, but I really believe you - I'm just curious which ones, because the
ones I'm using seem to be ok. And there are a lot of different ones...

but if you install them into WTK, you can use them by WTK. But when I
try to config running, internla error is thrown. Is is a bug or not?


Sound like a bug, yes.

Regards,
Edwin

0

Please sign in to leave a comment.