trouble exporting plugin -- now showing up in menus

After successfully debugging my plugin, I tried to publish it.

I followed the instructions here:
http://www.jetbrains.com/idea/webhelp/preparing-plugins-for-publishing.html

and made a jar file, no problem.

Then I want to IDEA settings and added the plugin using "Install Plugin from Disk" and restarted IDEA.

But once, relaunched, my plugin was not listed in the Tools menu where I expected it to be (and where it was when testing in debug mode).  Any suggestions how to properly export my plugin?

12 comments

Is the plugin listed in the plugin manager (Settings | Plugins)?

0

Yes, the plugin is listed there after restarting IDEA.  It's checkbox is also selected.

Here is relevant part of the plugin.xml:

<actions>
 <!-- Add your actions here -->
 <action id="generateP5Mini" text="ProcessingJS Minifier">
 <!--<add-to-group group-id="GenerateGroup" anchor="last"/>-->
 <add-to-group group-id="ToolsMenu" relative-to-action="GenerateJavadoc" anchor="after"/>
 </action>
</actions>



Note, I do have the Generate Javadoc in my Tools menu, so my menu should have somewhere to anchor after.
0

okay, starting up IDEA today, I get an error I've not seen before.

org/pleaseWork/p5minimizer/P5Mini : Unsupported major.minor version 51.0 [Plugin: org. pleaseWork.p5Minimizer]: org/pleaseWork/p5minimizer/P5Mini : Unsupported major.minor version 51.0 [Plugin: org. pleaseWork.p5Minimizer]
com.intellij.diagnostic.PluginException: org/pleaseWork/p5minimizer/P5Mini : Unsupported major.minor version 51.0 [Plugin: org. pleaseWork.p5Minimizer]
 at com.intellij.openapi.actionSystem.impl.ActionManagerImpl.a(ActionManagerImpl.java:261)
 at com.intellij.openapi.actionSystem.impl.ActionManagerImpl.a(ActionManagerImpl.java:223)
 at com.intellij.openapi.actionSystem.impl.ActionManagerImpl.getAction(ActionManagerImpl.java:216)
 at com.intellij.openapi.actionSystem.DefaultActionGroup.unstub(DefaultActionGroup.java:261)
 at com.intellij.openapi.actionSystem.DefaultActionGroup.getChildren(DefaultActionGroup.java:250)
 at com.intellij.openapi.actionSystem.impl.ActionManagerImpl$5.compute(ActionManagerImpl.java:1146)
 at com.intellij.openapi.actionSystem.impl.ActionManagerImpl$5.compute(ActionManagerImpl.java:1140)
 at com.intellij.openapi.application.impl.ApplicationImpl.runReadAction(ApplicationImpl.java:892)
 at com.intellij.openapi.actionSystem.impl.ActionManagerImpl.a(ActionManagerImpl.java:1140)
 at com.intellij.openapi.actionSystem.impl.ActionManagerImpl.a(ActionManagerImpl.java:1154)
 at com.intellij.openapi.actionSystem.impl.ActionManagerImpl.preloadActionGroup(ActionManagerImpl.java:1134)
 at com.intellij.openapi.actionSystem.impl.ActionManagerImpl.d(ActionManagerImpl.java:1126)
 at com.intellij.openapi.actionSystem.impl.ActionManagerImpl.access$200(ActionManagerImpl.java:69)
 at com.intellij.openapi.actionSystem.impl.ActionManagerImpl$4.run(ActionManagerImpl.java:1109)
 at com.intellij.openapi.application.impl.ApplicationImpl$6.run(ApplicationImpl.java:434)
 at java.util.concurrent.Executors$RunnableAdapter.call(Executors.java:439)
 at java.util.concurrent.FutureTask$Sync.innerRun(FutureTask.java:303)
 at java.util.concurrent.FutureTask.run(FutureTask.java:138)
 at java.util.concurrent.ThreadPoolExecutor$Worker.runTask(ThreadPoolExecutor.java:886)
 at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:908)
 at java.lang.Thread.run(Thread.java:680)
 at com.intellij.openapi.application.impl.ApplicationImpl$1$1.run(ApplicationImpl.java:145)
Caused by: java.lang.UnsupportedClassVersionError: org/pleaseWork/p5minimizer/P5Mini : Unsupported major.minor version 51.0
 at java.lang.ClassLoader.defineClass1(Native Method)
 at java.lang.ClassLoader.defineClassCond(ClassLoader.java:631)
 at java.lang.ClassLoader.defineClass(ClassLoader.java:615)
 at java.lang.ClassLoader.defineClass(ClassLoader.java:465)
 at com.intellij.util.lang.UrlClassLoader._defineClass(UrlClassLoader.java:125)
 at com.intellij.util.lang.UrlClassLoader.defineClass(UrlClassLoader.java:121)
 at com.intellij.util.lang.UrlClassLoader._findClass(UrlClassLoader.java:97)
 at com.intellij.ide.plugins.cl.PluginClassLoader.d(PluginClassLoader.java:102)
 at com.intellij.ide.plugins.cl.PluginClassLoader.loadClass(PluginClassLoader.java:63)
 at java.lang.ClassLoader.loadClass(ClassLoader.java:247)
 at java.lang.Class.forName0(Native Method)
 at java.lang.Class.forName(Class.java:247)
 at com.intellij.openapi.actionSystem.impl.ActionManagerImpl.a(ActionManagerImpl.java:245)
 ... 21 more

0

you should use JDK 1.6 for the plugin SDK

0

Switching the project's SDK to 1.6 (from built in IDEA) results in an error when I try to prepare the plugin for deployment.  (it also marks all of the PSI classes as unknown in my editor).

Then I rememebered to switch to the 1.6 version of the built in IDEA sdk.  Cool, that worked.

I rebuilt my plugin and then reinstalled it.

Haven't seen the errors again. :- )

Still not able to access my plugin either :- (

0

I would have liked to have tested it worked first, but, sure okay.

I will have it up by the end of the day.  Thanks.

0

Here we go (warning, first plugin and lots of mid-learning going on here):
https://github.com/jedierikb/p5Minimizer/

Any suggestions as to how to how make the plugin showup in the Tool menu?  I can make it work when in Debug mode, but not when I export the plugin as a jar, and then add the plugin to IntelliJ, and then restart (and after double checking the plugin is still listed and selected in the plugins list).

Thanks!

0

Works for me.

Actually first time I installed it, I did not see it, but maybe IJ did not restart. Then I installed it again, restarted and it worked :)

0

Thanks MEO,

Unfortunately, no matter how many times I uninstall, re-install, reboot over and over... nothing.  Hmm.  Unsure what to do. :-/

0

look to .IntelliJIdea12\config\plugins  and delete the plugin if it is there.

0

Got it to work.  Not sure what was going on there.  

Thank you!

0

Please sign in to leave a comment.