Plugin errors in PyCharm

The plugin runs fine in IDEA.

plugin.xml has the line

<depends>com.intellij.modules.lang</depends>

Which according to http://confluence.jetbrains.net/display/IDEADEV/Plugin+Compatibility+with+IntelliJ+Platform+Products should be enough to be able to run in PyCharm.
I can load the plugin in pycharm, but when I run it, I get an error:

Error during dispatching of java.awt.event.KeyEvent[KEY_PRESSED,keyCode=65,keyText=A,keyChar='a',modifiers=Alt,extModifiers=Alt,keyLocation=KEY_LOCATION_STANDARD,rawCode=65,primaryLevelUnicode=97,scancode=30] on frame0: com/intellij/ui/JBColor
java.lang.NoClassDefFoundError: com/intellij/ui/JBColor



I indeed use JBColor when creating the view. Should I not? What's going on?
1 comment
Comment actions Permalink

The JBColor class is a recent addition to the IntelliJ Platform. It's available in PyCharm 2.7 EAP but not in PyCharm 2.6.

0

Please sign in to leave a comment.