Apache Commons version problem

hi!

intellij provides in its jdk the apache-commons-httpclient-3.1-patched.jar which is now conflicting with the 4.2.1-version i'm using for my plugin. stepping back to v3.1 is no option.

using the new classes in 4.2.1 at some point the old classes of v. 3.1 get loaded and produce a java.lang.NoSuchMethodError as this functionality was introduced > 4.0.

how can i disable the shipped version of this jar?

2 comments
Comment actions Permalink

this is similiar but overriding an intellij-lib is no really possible.

i found another solution with repackaging the new version of the library with jarjar to include both versions of the same library

0

Please sign in to leave a comment.