j2mesupport Info

Hello
I just found out about the j2mesupport and I'd like to know if there is support for IDE4.0 or jtme 2.0 or 2.1?

Thanks,
- Cosmic

5 comments

Currently there is no official J2ME support in IDEA. There is a J2ME
plugin, but I've never used so perhaps somebody else could tell how it
works for them.

I create my J2ME setup like this:

1. Add new JDK, pick arbitrary one
2. Clear all the classes, docs, and sources
(look in the various tabs of the JDK dialog)
3. Add the WTK classes (WTK_HOME/lib/midpapi.zip)
4. Add the WTK javadoc (WTK_HOME/docs/api)
5. Install IdeaJAD if you need to peek at the WTK sources
(note that the WTK sources have nothing in common with
the phone implementation of MIDP. In the real world,
each vendor has different set of incompatibilities.)
6. Rename the newly created JDK to "WTK X.X"

When you create your project, pick the WTK and you should have all the
code completion and doc browsing features of IDEA. I do the compilation,
packaging and deployment with ant script (be sure to check
http://antenna.sf.net).

TIP: you can have JUnit tests for methods in your midlets if you make
them static. It's ugly, but it works.

QUESTION: Does somebody know of a project which provides mock J2ME
environment for J2ME unit tests? Is somebody interested
if I start writing one?

regards,
Dimiter

0

Hi,
there will be soon (in a week or two) new build of J2MESupport plugin, which runs under IDEA 4.0 and allows for MIDP2.0 development. Mean time you can try the old version in IDEA 3.x.

Best Regards,

Pavlin

0

Can someone make sure that it doesn't use Windows specific paths? I have the MIDP2.0 SDK for Linux and would like to use it their or MIDP1.0 SDK on OSX.

0

Hi,
there will be soon (in a week or two) new build of
J2MESupport plugin, which runs under IDEA 4.0 and
allows for MIDP2.0 development. Mean time you can try
the old version in IDEA 3.x.

Best Regards,

Pavlin


how does going on?

0

Hi,
there will be soon (in a week or two) new build of
J2MESupport plugin, which runs under IDEA 4.0 and
allows for MIDP2.0 development. Mean time you can try
the old version in IDEA 3.x.

Best Regards,

Pavlin


Hi Pavlin,

I'm using the IntelliJ 4.5 IDEA and WTK2.1 and i tried to install your J2MESupport Plugin, but i can't get to work. Can i please have some pointers?

/Magnus

0

Please sign in to leave a comment.