TabSwitch not working under Idea 4.5

The TabSwitch plugin 0.7 is not working under Idea 4.5 build 2192.
When try to use it, I get the error:

java.lang.NoClassDefFoundError:
com/intellij/openapi/ui/DialogWrapper$MyDialog
at
org.tzambalayev.ideaplugins.tabswitch.TabAction.actionPerformed(TabAction.ja
va:30)
at com.intellij.openapi.e.a.e.a(e.java:129)
at com.intellij.openapi.e.a.e.b(e.java:141)
at com.intellij.openapi.e.a.e.a(e.java:75)
at com.intellij.ide.t.a(t.java:66)
at com.intellij.ide.t.dispatchEvent(t.java:154)
at
java.awt.EventDispatchThread.pumpOneEventForHierarchy(EventDispatchThread.ja
va:201)
at
java.awt.EventDispatchThread.pumpEventsForHierarchy(EventDispatchThread.java
:151)
at java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:145)
at java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:137)
at java.awt.EventDispatchThread.run(EventDispatchThread.java:100)

And the plugin also does not appear in the Available Plugin list.

Thierry




3 comments
Comment actions Permalink

You can use version 0.7.1 available on the IntelliJ Community site:
http://www.intellij.org/twiki/bin/view/Main/TabSwitchPlugin

Bas

On 14-07-2004 17:11, ThierryLeveque wrote:

The TabSwitch plugin 0.7 is not working under Idea 4.5 build 2192.
When try to use it, I get the error:

java.lang.NoClassDefFoundError:
com/intellij/openapi/ui/DialogWrapper$MyDialog
at
org.tzambalayev.ideaplugins.tabswitch.TabAction.actionPerformed(TabAction.ja
va:30)
at com.intellij.openapi.e.a.e.a(e.java:129)
at com.intellij.openapi.e.a.e.b(e.java:141)
at com.intellij.openapi.e.a.e.a(e.java:75)
at com.intellij.ide.t.a(t.java:66)
at com.intellij.ide.t.dispatchEvent(t.java:154)
at
java.awt.EventDispatchThread.pumpOneEventForHierarchy(EventDispatchThread.ja
va:201)
at
java.awt.EventDispatchThread.pumpEventsForHierarchy(EventDispatchThread.java
:151)
at java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:145)
at java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:137)
at java.awt.EventDispatchThread.run(EventDispatchThread.java:100)

And the plugin also does not appear in the Available Plugin list.

Thierry



0
Comment actions Permalink

FYI 0.7.1 is now available from the plugin manager

Jacques

0
Comment actions Permalink

Ah, thank you! I have been planning to do this myself, but I could never
find the time.

Bas

On 17-07-2004 01:07, Jacques Morel wrote:

FYI 0.7.1 is now available from the plugin manager

Jacques

0

Please sign in to leave a comment.