junitgen - error

Hi All,
Has any one facing problem with junitgen plugin which is used to generate skeleton Test file?. When I use Alt+Insert nothing happens and no file generated.
And in system/log file it say cann't find junitgen.vm.
I double checked that and both junitgen.vm & junitgen.properties exists under /resources directory.

You help is appreciated.

OS: W2K
IDEA build #1181.
JDK 1.4.2

1 comment
Comment actions Permalink

Sanjeev,

I was having the exact same problem today and I tried a lot of things to get it to work. I don't have the "proper" fix to the problem, but here's something that might get you going until someone else posts the correct solution.

In the error log ($IDEA_HOME/bin/velocity.log), I noticed 2 things:
- adding path 'C:\IntelliJ-IDEA-4.0\bin\..\resources'
- that it could not find junitgen.vm in any of the resource directories

So I just copied the junitgen's resources directory to bin/../resources.

Though this is not the "correct" fix to the problem, it seems to have done the trick. If the above works for you, then ignore the rest of this posting (what's below).

I tried a lot of other steps prior to this, which did not seem to work. Ultimately, I ended up with the following directory structure:

$IDEA_HOME/plugins/junitgen/lib/junitgen.jar
$IDEA_HOME/plugins/junitgen/resources/]]>

Mine is IDEA build #1182.

-- paresh

0

Please sign in to leave a comment.