Perforce Plug in does not work with 4.0.3

I downloaded the 4.0.3 release and the Perforce Plugin is giving weird errors. Such as -- it claims that the files in the project are not on the client.

They clearly are, and switching back to 4.0.2 brings back the error free operation.

5 comments
Comment actions Permalink

I tried it here... seems like working fine.

Are there any exceptions in the log files ? if not starting IDEA with CTRL
key pressed will show more information as to why its not working...

-Dash.

"Randolph S Kahle" <no_mail@jetbrains.com> wrote in message
news:9301598.1082947722482.JavaMail.itn@is.intellij.net...

I downloaded the 4.0.3 release and the Perforce Plugin is giving weird

errors. Such as -- it claims that the files in the project are not on the
client.
>

They clearly are, and switching back to 4.0.2 brings back the error free

operation.


0
Comment actions Permalink

Thank you for the tip about the log files.

Everything went through a shutdown / backup cycle last night (including Perforce). After that, the plug in appears to be working correctly in 4.0.3.

Thank you for your support.

I really appreciate the work you have done on this plug in. It is making my life with IDEA and Perforce much easier. Thank you!

0
Comment actions Permalink

Glad to know you are finding the plugin useful and thanks for the kind
words....

-Dash.

"Randolph S Kahle" <no_mail@jetbrains.com> wrote in message
news:33502644.1083063543807.JavaMail.itn@is.intellij.net...

Thank you for the tip about the log files.

>

Everything went through a shutdown / backup cycle last night (including

Perforce). After that, the plug in appears to be working correctly in 4.0.3.
>

Thank you for your support.

>

I really appreciate the work you have done on this plug in. It is making

my life with IDEA and Perforce much easier. Thank you!
>
>


0
Comment actions Permalink

I'm having trouble with the plugin and 4.0.3 too. I've just upgrade from v3.x.x.

when i download and install this file:

http://www.intellij.org/twiki/pub/Main/PerforcePlugin/perforce.jar

I don't see perforce listed in the menu in the VCS setup.

when i download and install this file:

http://www.intellij.org/twiki/pub/Main/PerforcePlugin/perforce-pallada.jar

I see perforce listed in the menu, and the perforce menu show up in the menu bar and in my contextual menu. But there is nothing in either menu. they're empty!

It also won't let me check things out by starting to edit them either.

Help please!

-Evan

0
Comment actions Permalink

I think you need the version for 4.0.x not the 3.0 or pallada one. so please
do the following and let me know if it works.

remove the perforce.jar and perfroce-pallada.jar from your plugins
directory. and then you start IDEA , go to "plugins" in the project
properties and download the PerforcePlugin from there.. Restart IDEA again
and you should have the plugin working.

Thanks,
-Dash.

"Evan Leonard" <no_mail@jetbrains.com> wrote in message
news:20604349.1084475623169.JavaMail.itn@is.intellij.net...

I'm having trouble with the plugin and 4.0.3 too. I've just upgrade from

v3.x.x.
>

when i download and install this file:

>

http://www.intellij.org/twiki/pub/Main/PerforcePlugin/perforce.jar

>

I don't see perforce listed in the menu in the VCS setup.

>

when i download and install this file:

>

http://www.intellij.org/twiki/pub/Main/PerforcePlugin/perforce-pallada.jar

>

I see perforce listed in the menu, and the perforce menu show up in the

menu bar and in my contextual menu. But there is nothing in either menu.
they're empty!
>

It also won't let me check things out by starting to edit them either.

>

Help please!

>

-Evan

>
>


0

Please sign in to leave a comment.