Re: Values for since-build in <idea-version> of plugin.xml?

Hello Chris,

Just to be clear: Are you saying that it might be best to leave out
the until-build attribute completely?


If you do know that the API has changed, and have multiple versions of the
plugin compatible with different API versions, then the version for the old
API must have the until-build set, in order for all users to get the correct
version.

If you simply have a plugin that works with the latest version, then it's
best to leave out the until-build.

(Right now there's some extra problems because the plugin manager Web site
doesn't handle 90.xxx build numbers correctly just yet, but we're working
on solving this.)

--
Dmitry Jemerov
Development Lead
JetBrains, Inc.
http://www.jetbrains.com/
"Develop with Pleasure!"


7 comments
Comment actions Permalink

Glad to hear that you are working on the webpage issue.  However, I think it is more than just a webpage issue.  IJ8.1.3 is mistakenly detecting my latest plugin version, that is configured to only be valid for 90.0 or higher, to be available for download.  I think one of my users downloaded it for 8.1.3 and now it doesn't work.  How do I prevent 8.X users from downloading my 9.0 compatible plugin?

0
Comment actions Permalink

Hello Shawn,

This is actually the same issue. IDEA downloads the list of plugins from
the plugins.intellij.net Website, and it doesn't do proper build number filtering
at the moment.

Glad to hear that you are working on the webpage issue.  However, I
think it is more than just a webpage issue.  IJ8.1.3 is mistakenly
detecting my latest plugin version, that is configured to only be
valid for 90.0 or higher, to be available for download.  I think one
of my users downloaded it for 8.1.3 and now it doesn't work.  How do I
prevent 8.X users from downloading my 9.0 compatible plugin?


--
Dmitry Jemerov
Development Lead
JetBrains, Inc.
http://www.jetbrains.com/
"Develop with Pleasure!"


0
Comment actions Permalink

What about the problem I keep seeing whereby IDEA doesn't tell me that a
newer version of a plugin is available to install, is that also related?
Eg currently I have BashSupport 0.9.4 installed. I happen to know there is
a 0.9.5 version available but I have to go to the "Available" tab and manually
right-click on it and select "Download and Install". IDEA used to tell me
the version I had was out of date by highlighting it in blue(?) on the "Installed"
tab, but I haven't seen that work for many/any plugins in quite a while now
(since a few months back during the Maia EAP I think).

Chris


DJ> Hello Shawn,
DJ>
DJ> This is actually the same issue. IDEA downloads the list of plugins
DJ> from the plugins.intellij.net Website, and it doesn't do proper
DJ> build number filtering at the moment.
DJ>
>> Glad to hear that you are working on the webpage issue.  However, I
>> think it is more than just a webpage issue.  IJ8.1.3 is mistakenly
>> detecting my latest plugin version, that is configured to only be
>> valid for 90.0 or higher, to be available for download.  I think one
>> of my users downloaded it for 8.1.3 and now it doesn't work.  How do
>> I prevent 8.X users from downloading my 9.0 compatible plugin?


0
Comment actions Permalink

I have my BulkLoadModules plugin set for since-build="8000" but it only shows up for IJ9 Ultimate.  Do I have to do anything to get it to show up for IJ9 Community?  Do I have to build with community IJ perhaps?

0
Comment actions Permalink

There seem to be a bunch of other problems as well with the plugin versioning.

Just to mention one, if i use <idea-version since-build="10000"/>, the plugin shows as compatible with all Intellij CE / WebIDE / RubyMine in the plugin repository. But when i try to download it over plugin manager in RubyMine, it gets the binaries for <idea-version since-build="8000" until-build="9999"/>, and the plugin gets disabled on the first run because of several incompatibility issues. Installing the plugin manually seems to be an option, but the value since-build="10000" is not accepted by RubyMine 2.0, so again, the plugin shows as incompatible. So i have to remove the idea-version tag all together and then it works.

I think JetBrains people should set more priority in fixing these issues, because it is been a while now since users started complaining about them...

0
Comment actions Permalink

Hello Dan,

This specific problem is a bug in RubyMine 2.0 which has already been fixed
in RubyMine 2.0.1.

There seem to be a bunch of other problems as well with the plugin
versioning.

Just to mention one, if i use <idea-version since-build="10000"/>, the
plugin shows as compatible with all Intellij CE / WebIDE / RubyMine in
the plugin repository. But when i try to download it over plugin
manager in RubyMine, it gets the binaries for <idea-version
since-build="8000" until-build="9999"/>, and the plugin gets disabled
on the first run because of several incompatibility issues. Installing
the plugin manually seems to be an option, but the value
since-build="10000" is not accepted by RubyMine 2.0, so again, the
plugin shows as incompatible. So i have to remove the idea-version tag
all together and then it works.

I think JetBrains people should set more priority in fixing these
issues, because it is been a while now since users started complaining
about them...

---
Original message URL:
http://www.jetbrains.net/devnet/message/5254535#5254535

--
Dmitry Jemerov
Development Lead
JetBrains, Inc.
http://www.jetbrains.com/
"Develop with Pleasure!"


0
Comment actions Permalink

Indeed, seems to be working now. Thanks!

0

Please sign in to leave a comment.