tmate: feature request (new sort order)

In the team changes, the dates are sorted in ascending order. But the
times within a date are sorted in decending order. I would like the
ability to sort transactions with decending order.

6 comments

Hello,

Looks more like a bug, than a feature. I suppose that top change is always the newest one the same way as "date" and "week" nodes are displayed. Am I understand correct that what you see in TMate window is something like (or is it what you would like to see? :)):

Thanks,
Alexander Kitaev.

0


Alexander Kitaev wrote:


10 february
10:00 bugfix1
11:00 bugfix2
09 february
09:00 early in the morning change
21:00 late in the night bugfix


The above is what I currently see. I would like always to see the latest
changes at the top:

10 february
11:00 bugfix2
10:00 bugfix1
09 february
21:00 late in the night bugfix
09:00 early in the morning change


0

Hello,

This is not expected behaviour, I suppose it will be fixed in the next build.

By the way, may I ask you whether "go to source" and related features are working correctly with the latest TMate build in your environment?

Thanks,
Alexander Kitaev.

0


Alexander Kitaev wrote:

This is not expected behaviour, I suppose it will be fixed in the next build.


Ok, thanks.

By the way, may I ask you whether "go to source" and related features are working correctly with the latest TMate build in your environment?


No. Whenver I select a file (in the "TMate" view) it indicates in the
status bar "Module 'whatever' is not in the project ". When I
click the light-bulb the 'Checkout Modules' dialog is presented with the
module that is 'not in the project' selected. Whenever I select any of
the modules in the 'Select modules:' list, the 'VCS Properties'
indicates for the the selected 'Module is not in the project'.


So I'm quite confused. I even completely rebuilt all the settings from
scratch and had the server reindex. But no difference in behavior.

(I've attached some screen-shots, but don't know if it will make thru.
Let me know.)



Attachment(s):
snap_001.gif
snap_002.gif
0

Hello,

Hm. To exclude all the external problems, could you please check whether "cvs" version control support is set up for your project? To set up vcs for the project you may use "File | Settings | Version Control" and select "CVS" in the vcs settings dialog combobox. If there was "]]>" selected it could be the reason of the problem. After applying this change, please restart IDEA.

Thanks,
Alexander Kitaev.

0

CVS is fully functional within idea. I use it extensively.

Alexander Kitaev wrote:

Hello,

Hm. To exclude all the external problems, could you please check whether "cvs" version control support is set up for your project? To set up vcs for the project you may use "File | Settings | Version Control" and select "CVS" in the vcs settings dialog combobox. If there was "<None>" selected it could be the reason of the problem. After applying this change, please restart IDEA.

Thanks,
Alexander Kitaev.


0

Please sign in to leave a comment.