IDEA 7.0.3 Plugins, JDK1.6 and Mac

Hi,

I developed a plugin initially for IDEA-6 plugin sdk and tested it both on Windows and Mac-OS-X with IDEA-7.0.3.
Now I try to switch to the sdk of 7.0.3. However it requires jdk1.6 and while working on Windows, when trying to run it on the Mac which comes pre-installed with JDK1.5 the plugin fails to load because of incompatible classfiles.
I guess I can solve this by installing JDK1.6 on the Mac (which is now available) but I don't want to force it - IDEA-7.0.3 works fine on Mac with JDK1.5.

Why does the sdk of 7.0.3 requires jdk1.6 ?

thanks,
Shmulik

4 comments
Comment actions Permalink

Hello Shmulik,

I developed a plugin initially for IDEA-6 plugin sdk and tested it
both on Windows and Mac-OS-X with IDEA-7.0.3.

Now I try to switch to the sdk of 7.0.3. However it requires jdk1.6
and while working on Windows, when trying to run it on the Mac which
comes pre-installed with JDK1.5 the plugin fails to load because of
incompatible classfiles.

I guess I can solve this by installing JDK1.6 on the Mac (which is now
available) but I don't want to force it - IDEA-7.0.3 works fine on Mac
with JDK1.5.

Why does the sdk of 7.0.3 requires jdk1.6 ?


Please see the following page for a detailed description of this issue:
http://www.jetbrains.net/confluence/display/IDEADEV/BuildingPluginswithIntelliJIDEA+7.0

--
Dmitry Jemerov
Development Lead
JetBrains, Inc.
http://www.jetbrains.com/
"Develop with Pleasure!"


0
Comment actions Permalink

Hi,

Thanks, I just found it and intended to respond myself.
I managed to compile the plugin so that it works both on windows and mac with that version.
I had to mark the plugin module as a regular module and include the jars - openapi.jar, jdom.jar, annotation.jar and extensions.jar from the special distribution version, and packaged the plugin with Ant.

If changes are made to the openapi in 7.*, please continue to maintain a jdk1.5 compatible version. jdk1.6 in fairly new on mac and I don't think many mac users will jump to install it.

thanks,
Shmulik

0
Comment actions Permalink

in fact it doesn't require jdk 1.6 but strangely the 1.5 compatible version is not available on http://www.jetbrains.com/idea/download/index.html#kit

You may find the latest EAP's one here http://www.jetbrains.net/confluence/display/IDEADEV/Selena+EAP

0
Comment actions Permalink

Hello Shmulik,

If changes are made to the openapi in 7.*, please continue to maintain
a jdk1.5 compatible version. jdk1.6 in fairly new on mac and I don't
think many mac users will jump to install it.


We do not currently have any plans to drop the jdk15 builds of IDEA.

--
Dmitry Jemerov
Development Lead
JetBrains, Inc.
http://www.jetbrains.com/
"Develop with Pleasure!"


0

Please sign in to leave a comment.