License collision during plugin development on Linux

Hi,

I wonder if this might be a possible bug in the Linux version of IDEA?

I'm trying to develop a plugin. And following the tutorial, I run the plugin from the IDE, which spawns another copy of IDEA to test the plugin. But when this happens, I always get the following:

License Collision Detected

This license is being used elsewhere on the network by myHost (127.0.1.1).
Only one active computer a time can use the license...

And so on. (And no, that is not a typo, it does say the host is 127.0.1.1, not 127.0.0.1 as I would have expected.

Anyway, if I click yes, to reactive, the other copy of the IDE gets the license collision, and lists the same host and IP address.

It seems for some reason it doesn't realize that both copies are running on the same computer. Am I missing something? Or is this a bug in the Linux version?

System setup is as follows:

Ubuntu Feisty Fawn AMD64
Most recent AMD 64 Sun JDK
IDEA 6.0.5

Thanks for any suggestions.

3 comments

Just configure your firewall to eat all UDP packets sent to 230.0.0.3

0

I'm having this exact same problem on OSX, with the Selena builds (haven't tried the 6.0 version). How can I get around it to test a plugin?

0

If you don't click any of the buttons in the idea you use for development, then the plugin one will work fine. Once you close the plugin idea, you have to click yes, and you'll get all the system outs and traces in your development idea.

Carolina

0

Please sign in to leave a comment.