Wrong version of IDEA-JAD on plugins.intellij.net

The version of IDEA-JAD on plugins.intellij.net is, for some reason, the
version which works with build 691 of IDEA. If you install this through the
new plugin manager, IDEA starts throwing a lot of exceptions when you
restart it. There is a version of the plugin available from intellij.org
which works with build 922 (and appears fine with 957 as well). Is there any
way to change the plugins.intellij.net entry to point at this instead?

Vil.
--
Vilya Harvey
vilya.harvey@digitalsteps.com / digital steps /
(W) +44 (0)1483 469 480
(M) +44 (0)7816 678 457 http://www.digitalsteps.com/

3 comments

Just upload the new one as an update.
Remember, folks, the plugin manager is for Aurora, so plugins
for the current release need not be included.

Vilya Harvey wrote:

The version of IDEA-JAD on plugins.intellij.net is, for some reason, the
version which works with build 691 of IDEA. If you install this through
the new plugin manager, IDEA starts throwing a lot of exceptions when
you restart it. There is a version of the plugin available from
intellij.org which works with build 922 (and appears fine with 957 as
well). Is there any way to change the plugins.intellij.net entry to
point at this instead?

Vil.


--

Erb

==============================================================
"Most of you are familiar with the virtues of a programmer.
There are three, of course: laziness, impatience, and hubris."
- Larry Wall
==============================================================

0

Erb wrote:

Just upload the new one as an update.
Remember, folks, the plugin manager is for Aurora, so plugins
for the current release need not be included.

Vilya Harvey wrote:

>> The version of IDEA-JAD on plugins.intellij.net is, for some reason,
>> the version which works with build 691 of IDEA. If you install this
>> through the new plugin manager, IDEA starts throwing a lot of
>> exceptions when you restart it. There is a version of the plugin
>> available from intellij.org which works with build 922 (and appears
>> fine with 957 as well). Is there any way to change the
>> plugins.intellij.net entry to point at this instead?
>>
>> Vil.


I tried to upload the 922 plugin as zipped directory using 'add version'.
That did not work - the server responded that the version already
existed. I guess that the plugin.xml description should be updated

Edo

0

Edoardo Comar wrote:

Erb wrote:

>> Just upload the new one as an update.
>> Remember, folks, the plugin manager is for Aurora, so plugins
>> for the current release need not be included.
>>
>> Vilya Harvey wrote:
>>
>>> The version of IDEA-JAD on plugins.intellij.net is, for some reason,
>>> the version which works with build 691 of IDEA. If you install this
>>> through the new plugin manager, IDEA starts throwing a lot of
>>> exceptions when you restart it. There is a version of the plugin
>>> available from intellij.org which works with build 922 (and appears
>>> fine with 957 as well). Is there any way to change the
>>> plugins.intellij.net entry to point at this instead?
>>>
>>> Vil.
>>
>>
>>

I tried to upload the 922 plugin as zipped directory using 'add version'.
That did not work - the server responded that the version already
existed. I guess that the plugin.xml description should be updated

Edo

OK done that, I changed the vesion element in the plugin to be 1.0.922-1
and my upload was accepted

0

Please sign in to leave a comment.