Is There A Document Describing Exact Steps To Make Clover Work In IDEA?

Greetings, All.

I've found in the forum discussions of others who have
tried to use Clover in IDEA. I just downloaded IDEA
(got version 3.0.4, build 701) and when I paste a Clover
task into my build.xml it shows up in red and doesn't
work. When I double click on it, I get a message from
Ant telling me "Could not create task or task type of
type: clover-setup.".

One of the mysteries to me that seems obvious to most of
you is how I set my ANT_HOME which appears to be crucial
to getting this to work. I've been able to use Ant with
JUnit up until now without having to set ANT_HOME (at
least on Windows XP). Perhaps someone can describe where
I should point this variable to on XP.

I'd really like to see a document (if anyone has one) of
exactly what steps are needed to make this stuff work on
XP or even on any platform. The last message of one of
the threads seemed to indicate that the Clover/IDEA
integration could be broken.

Thanks for your feedback,
-David Swift

6 comments

Click on the Ant properties icon (toolbar of the ant window). Add clover.jar to the ant classpath

Jacques

0

I've had clover.jar in the Additional Class Path tab of the Ant Build properties page from hour 1. It didn't seem to make a difference.

0

David Swift wrote:

I've had clover.jar in the Additional Class Path tab of the Ant Build properties page from hour 1. It didn't seem to make a difference.


looks like it may be related to my problem with optional tasks as well :

http://www.intellij.net/tracker/idea/viewSCR?publicId=10019

I opened it with IDEA 3.0 and the bug has never been opened, although I
tried to oepn a thread in the eap group recently

Edo

0

Just to make sure, you've restarted IDEA or at least closed and reopened your project, right? I've noticed that sometimes IDEA won't stop marking a task as red until I close and reopen the project.

Also, I've noticed that simply having required jar on my classpath and then checking Include project classpath in the Build File Properties isn't enough. To get it to work, I had to explicitly add the jar to the Additional Classpath. Weird.

0

I restarted IDEA multiple times and the tasks were still in red, so I (falsely) assumed that I was still screwed. It appears, however, that I'm getting further now. I'm getting complaints that the build is unable to read the Clover coverage database. It would be nice if the tasks didn't appear in red unless they were indeed invalid.

Thanks for your help, everyone.

0

David,

Put clover.jar to IDEA/lib folder (this is a known issue in Ariadna).

--
Best regards,
Mike Aizatsky.
-


JetBrains, Inc / IntelliJ Software
http://www.intellij.com
"Develop with pleasure!"


0

Please sign in to leave a comment.