Why I always meet this error?

I want to write a opentool, but when I compile the files, it will occur this error:

Error: line (3) cannot access com.intellij.openapi.actionSystem.AnAction
bad class file: D:\IntelliJ-IDEA-3.0.2\lib\openapi.jar(com/intellij/openapi/actionSystem/AnAction.class)
class file has wrong version 48.0, should be 47.0
Please remove or make sure it appears in the correct subdirectory of the classpath.

2 comments

This most probably means that you're trying to compile your plugin against
some version of JDK 1.3. Try using JDK 1.4 instead.

Vil.

ioat wrote:

I want to write a opentool, but when I compile the files, it will occur this error:

Error: line (3) cannot access com.intellij.openapi.actionSystem.AnAction
bad class file: D:\IntelliJ-IDEA-3.0.2\lib\openapi.jar(com/intellij/openapi/actionSystem/AnAction.class)
class file has wrong version 48.0, should be 47.0
Please remove or make sure it appears in the correct subdirectory of the classpath.


--
Vilya Harvey, Consultant
vilya.harvey@digitalsteps.com / digital steps /
(W) +44 (0)1483 469 480
(M) +44 (0)7816 678 457 http://www.digitalsteps.com/

Disclaimer

This e-mail and any attachments may be confidential and/or legally
privileged. If you have received this email and you are not a named
addressee, please inform the sender at Digital Steps Ltd by phone on
+44 (0)1483 469 480 or by reply email and then delete the email from
your system. If you are not a named addressee you must not use,
disclose, distribute, copy, print or rely on this email. Although
Digital Steps Ltd routinely screens for viruses, addressees should
check this email and any attachments for viruses. Digital Steps Ltd
makes no representation or warranty as to the absence of viruses in this
email or any attachments.

0

Please sign in to leave a comment.