Registering a new file type

Hi all,

I am developing a custom language and registered a new file type, the
default extension is '.asa'

Unfortunately the new file type is not visible within the IDE?

Things I have checked:-
- Settings->General (Ignore files and folders) <!-- This is fine -->
- The file I have created is in a project. <!-- This is fine -->

Has anybody experienced this problem before and have a resolution?

Thanks in advance.

Regards
- Percy

4 comments
Comment actions Permalink

That is trouble indeed?

0
Comment actions Permalink

Hello Percy,

PW> I am developing a custom language and registered a new file type,
PW> the default extension is '.asa'
PW>
PW> Unfortunately the new file type is not visible within the IDE?
PW>
PW> Things I have checked:-
PW> - Settings->General (Ignore files and folders) <!-- This is fine -->
PW> - The file I have created is in a project. <!-- This is fine -->
PW> Has anybody experienced this problem before and have a resolution?

What exactly do you mean? Do you mean that you can't see the files with .asa
extension in the project view, or that you can't see your file type in Settings
| File Types?

--
Dmitry Jemerov
Software Developer
http://www.jetbrains.com/
"Develop with Pleasure!"


0
Comment actions Permalink

I can't see any files with the extension .asa in the project view.


On 1/9/06 15:37, in article c8a8949df7a9f8c89c0cd74176f1@news.jetbrains.com,
"Dmitry Jemerov" <yole@jetbrains.com> wrote:

Hello Percy,

PW> I am developing a custom language and registered a new file type,
PW> the default extension is '.asa'
PW>
PW> Unfortunately the new file type is not visible within the IDE?
PW>
PW> Things I have checked:-
PW> - Settings->General (Ignore files and folders) <!-- This is fine -->
PW> - The file I have created is in a project. <!-- This is fine -->
PW> Has anybody experienced this problem before and have a resolution?

What exactly do you mean? Do you mean that you can't see the files with .asa
extension in the project view, or that you can't see your file type in
Settings
| File Types?


0
Comment actions Permalink

I have solved this problem. Well I rebuilt the registering file type classes
from scratch and deleting the plugin created in sandbox/plugin directory.

On 1/9/06 15:37, in article c8a8949df7a9f8c89c0cd74176f1@news.jetbrains.com,
"Dmitry Jemerov" <yole@jetbrains.com> wrote:

Hello Percy,

PW> I am developing a custom language and registered a new file type,
PW> the default extension is '.asa'
PW>
PW> Unfortunately the new file type is not visible within the IDE?
PW>
PW> Things I have checked:-
PW> - Settings->General (Ignore files and folders) <!-- This is fine -->
PW> - The file I have created is in a project. <!-- This is fine -->
PW> Has anybody experienced this problem before and have a resolution?

What exactly do you mean? Do you mean that you can't see the files with .asa
extension in the project view, or that you can't see your file type in
Settings
| File Types?


0

Please sign in to leave a comment.