4 comments
Comment actions Permalink

For plugin module you need to set Intellij IDEA SDK

Mickael Remond wrote:

Hello,

I am playing with the Open API and get the following error on my first try:
"wrong jdk type for plugin module"

I am using IDEA 5.1.1.
Any idea of what I could have done wrong ?



--
Best regards,
Maxim Mossienko
IntelliJ Labs / JetBrains Inc.
http://www.intellij.com
"Develop with pleasure!"

0
Comment actions Permalink

I thought I had installed it. That's why I intended.
I copied the SDK archive into my Idea directory.
Is it not sufficient ?

--
Mickaël Rémond

0
Comment actions Permalink

No, that's not enough. You have to go to Settings -> JDK & Global Libraries and create an 'IntelliJ IDEA SDK' (second 'add' button in JDK tab). That's a special JDK for plugin development which contains the JDK used by IDEA itself and all the necessary libraries like openapi.jar.

0
Comment actions Permalink

I missed this step.
My config is up and running now.
Thank you !

--
Mickaël Rémond

0

Please sign in to leave a comment.