since-build question

What should this be for 4.0.x and greater? That is, my plugin works with
the 4.0.x builds and above (Pallada eap and now 4.5).

4 comments
Comment actions Permalink

since-build="1178"

0
Comment actions Permalink

Jacques Morel wrote:

since-build="1178"

Thanks. Turns out it doesn't work with both versions though. Ugh.

0
Comment actions Permalink

File a bug report. My understanding is that
1. Old plugin with no since-build are considered not compatible with 4.5
2. Any plugin with a since-build should be presented in any build
greater that the "since-build" attribute.

BTW did you specify idea min or max version as well? Maybe it is conflicting.

Anyhow there are been a lot of bugs around the plugin manager. I would
not be surprised this is another one. It is hopefully one however that
is quick to workaround

Jacques

0
Comment actions Permalink

Jacques Morel wrote:

File a bug report. My understanding is that
1. Old plugin with no since-build are considered not compatible with 4.5
2. Any plugin with a since-build should be presented in any build
greater that the "since-build" attribute.

BTW did you specify idea min or max version as well? Maybe it is conflicting.

Anyhow there are been a lot of bugs around the plugin manager. I would
not be surprised this is another one. It is hopefully one however that
is quick to workaround

Jacques

I'm sorry, I wasn't clear. I meant the plugin that I am developing
doesn't work with both versions so I will have to have two different
versions. It's not a bug. Thanks again.

0

Please sign in to leave a comment.