Messages showDialog doesn't show

Perhaps I have to do some AWT tricks but this is what happens:
- Shift-F6 - rename class
- IDEA opens dialog to type the new name
- type it and hit OK (the preview is OFF)
- beforePropertyChange called
- inside I open a new dialog Messages.show...
- AND IT DOESN'T SHOW UP
(it must be some events not cleared because if I do it twice, the second
dialog shows just fine)

For comparison:
- Shift-F6 - rename class
- IDEA opens dialog to type the new name
- type it and hit OK (the preview is ON)
- type ALT-D (Do refactor)
- beforePropertyChange called
- inside I open a new dialog Messages.show...
- and it shows up without any problems
(if I do it twice, the second dialog shows as well)


Can anyone suggest what to do? I'm almost ready to post new Perforce plugin
just wanted
to fix this issue.

r.


3 comments

I apparently forgot to say "PLEASE, can someone help?".
r.

"Richard Nemec" <rndzank@attbi.com> wrote in message
news:b5vard$rqb$1@is.intellij.net...

Perhaps I have to do some AWT tricks but this is what happens:
- Shift-F6 - rename class
- IDEA opens dialog to type the new name
- type it and hit OK (the preview is OFF)
- beforePropertyChange called
- inside I open a new dialog Messages.show...
- AND IT DOESN'T SHOW UP
(it must be some events not cleared because if I do it twice, the second
dialog shows just fine)

>

For comparison:
- Shift-F6 - rename class
- IDEA opens dialog to type the new name
- type it and hit OK (the preview is ON)
- type ALT-D (Do refactor)
- beforePropertyChange called
- inside I open a new dialog Messages.show...
- and it shows up without any problems
(if I do it twice, the second dialog shows as well)

>
>

Can anyone suggest what to do? I'm almost ready to post new Perforce

plugin

just wanted
to fix this issue.

>

r.

>
>


0

Sorry, I have no experience in this particular situation. Hopefully someone from
JB will have time to answer this.
(Any chance something is shown in the log file?)
Also, check if the parent window you are giving it is visible
(just a random thought)

Richard Nemec wrote:

I apparently forgot to say "PLEASE, can someone help?".
r.

"Richard Nemec" <rndzank@attbi.com> wrote in message
news:b5vard$rqb$1@is.intellij.net...

>>Perhaps I have to do some AWT tricks but this is what happens:
>>- Shift-F6 - rename class
>>- IDEA opens dialog to type the new name
>>- type it and hit OK (the preview is OFF)
>>- beforePropertyChange called
>>- inside I open a new dialog Messages.show...
>>- AND IT DOESN'T SHOW UP
>> (it must be some events not cleared because if I do it twice, the second
>> dialog shows just fine)
>>
>>For comparison:
>>- Shift-F6 - rename class
>>- IDEA opens dialog to type the new name
>>- type it and hit OK (the preview is ON)
>>- type ALT-D (Do refactor)
>>- beforePropertyChange called
>>- inside I open a new dialog Messages.show...
>>- and it shows up without any problems
>> (if I do it twice, the second dialog shows as well)
>>
>>
>>Can anyone suggest what to do? I'm almost ready to post new Perforce


plugin

>>just wanted
>>to fix this issue.
>>
>>r.
>>
>>




--

Erb

==============================================================
"Most of you are familiar with the virtues of a programmer.
There are three, of course: laziness, impatience, and hubris."
- Larry Wall
==============================================================

0

- it happens in both 695 and 807
- I believe the message window shows for a fraction of second
and then closes without any user activity
(and I get the return value that is different from the default button
index)
- and, there is nothing in the log
(unless I need to turn something on to get more info)
- there is just one project opened and it is visible

r.

"Erb" <dont@evenbother.com> wrote in message
news:b61uso$6ks$1@is.intellij.net...

Sorry, I have no experience in this particular situation. Hopefully

someone from

JB will have time to answer this.
(Any chance something is shown in the log file?)
Also, check if the parent window you are giving it is visible
(just a random thought)

>

Richard Nemec wrote:

I apparently forgot to say "PLEASE, can someone help?".
r.

>

"Richard Nemec" <rndzank@attbi.com> wrote in message
news:b5vard$rqb$1@is.intellij.net...

>
>>Perhaps I have to do some AWT tricks but this is what happens:
>>- Shift-F6 - rename class
>>- IDEA opens dialog to type the new name
>>- type it and hit OK (the preview is OFF)
>>- beforePropertyChange called
>>- inside I open a new dialog Messages.show...
>>- AND IT DOESN'T SHOW UP
>> (it must be some events not cleared because if I do it twice, the

second

>> dialog shows just fine)
>>
>>For comparison:
>>- Shift-F6 - rename class
>>- IDEA opens dialog to type the new name
>>- type it and hit OK (the preview is ON)
>>- type ALT-D (Do refactor)
>>- beforePropertyChange called
>>- inside I open a new dialog Messages.show...
>>- and it shows up without any problems
>> (if I do it twice, the second dialog shows as well)
>>
>>
>>Can anyone suggest what to do? I'm almost ready to post new Perforce
>

plugin

>
>>just wanted
>>to fix this issue.
>>
>>r.
>>
>>
>
>
>

>
>

--

>

Erb

>

==============================================================
"Most of you are familiar with the virtues of a programmer.
There are three, of course: laziness, impatience, and hubris."
- Larry Wall
==============================================================

>


0

Please sign in to leave a comment.