Ann:WebServices plugin 0.5 build 1 is available

Change notes:
- Works with IDEA 6 (Demetra, builds 5000) and IDEA 5/5.1 builds (Irida, builds 3000,4000+)
- Bug fixes.

14 comments

OK, downloading and testing.... Thanks.

0

I have got an error:
java.lang.UnsupportedClassVersionError: Bad version number in .class file


Could this be the problem in the previous version too?
I'm using Java 1.6.0 b77

Thanks...

0

It is quite likely (but now we can see the problem:).
You can run IDEA using Java 1.6 and the problem will go away.

0

How can I run Idea with Java1.6?

0

Oh, i have to just run idea.bat, and set the JDK_HOME to the JDK1.6 dir?

0

Java version mismatch when trying to run idea with Java 1.6...

"The JDK version is 1.6.0-beta2
IDEA requires JDK1.4.2 or higher or JDK 1.5"

0

'set JDK_HOME=C:\Program Files\Java\jdk1.6.0' in 'idea.bat' at the top of the file -and-
maybe 'idea.no.jdk.check=true' in 'idea.properties'

0

I gernerate WSDL from Java, and the idea is exiiting without message.
After restarting idea, the wsdl file is there...

I haven't found any exception printing in idea's log.

0

I restartewd, and i wanted to publish Web services from class. i received this window (in attaachment).

I think, i don't know how to use this plugin, is there any information or tutorial?

Thanks...



Attachment(s):
wsTest.jpg
0

You need to run your web module with this context name set

0

Are there any hsXXX.log files appeared in bin directory of IDEA?

0

No, there isn't any hsXXX.log file there.

0

WebServices tab contain the information, e.g. it has page on web service development linked from its first page, you can also press Help button on corresponding dialog that opens the tab with relevant information for this dialog.

0

I mean HotSpot crash files like hs_err_pid868.log.
Anyway the problem was reproduced with Java 1.6, investigating possible fix

0

Please sign in to leave a comment.