Use of Kotlin & Gradle in 143.379 EAP

Getting various errors about unsupported libarary formats for kotlin libs.

MUPanel.png

Then lists the kotlin run and an RxKotlin lib.

Any ideas ?

Have tried deleteing all project info with no success, a new kotlin gradle plugin ? Am currentling using 0.14.449

Thanks

4 comments
Comment actions Permalink

Ok found the kotlin gradle plugin of 1.0.0-beta-1038

Now I get

This should not be shown.png

0
Comment actions Permalink

The support for external annotations has been removed in Kotlin 1.0 beta, so you need to remove the corresponding property from your build.gradle.

0
Comment actions Permalink

Thanks, seems to be up and running.

Still getting an error with the other lib, though not a jetbrains issue.

Are there any docs on the compatibility of formats between kotlin versions ? Or is this just because it's not released yet and no attempt to keep a consistent format ?

Thanks

0
Comment actions Permalink

Changes between Kotlin versions are announced on the Kotlin blog. In this particular case, you started using a EAP build of IDEA with a new version of Kotlin before those versions of IDEA and Kotlin were announced, so the information wasn't available. Now the blog post is published: http://blog.jetbrains.com/kotlin/2015/10/kotlin-1-0-beta-candidate-is-out/

0

Please sign in to leave a comment.