Chrome custom user profile for javascript debugging?

Answered

The docs refer to the ability to setup an alternate chrome profile to use for javascript debugging when you are also using chrome as your regular browser. It doesn't actually show you how to do that though ;-). An old blog post shows editing the browser configuration, it's under Preferences/Tools/Browsers on a Mac.

But no combination of Use custom profile directory or command line options seems to change anything. When I launch my javascript debug definition, which is now pointing to a new Browser definition called Chrome-debug, it always launches into the Default profile, and shows the debugger in all my open windows.

I've tried pointing the custom profile to the default, a folder under the Idea application folder, a folder outside of the application folder, and the folder chrome setup for my debug profile, ~/Library/Application Support/Google/Chrome/Profile 1/

Hints? anybody have this working?

3 comments
Comment actions Permalink

This has to be configured in Preferences/Tools/Web Browsers, 'Use custom profile directory' option. Currently debugger seems to use the first listed profile with extension installed - see https://youtrack.jetbrains.com/issue/WEB-16489.

Note also that these settings are only used when no Chrome instances are run - if the system has already running Google Chrome process, debugger connects to it and uses it for debugging, command line options set in browser configuration are only used when launching a new Chrome instance

0
Comment actions Permalink

Ok, so one part of the mystery is more clear. I cannot have Chrome running at all when I launch a debug configuration or it will start in the open Chrome is what you are saying. I'd say that is a bit of pain for a developer to be honest. I tend to have a LOT of windows/tabs open in Chrome while I work.

The other part is still unclear to me. So I closed Chrome and launched the debugger. The default profile still opened up. Yes I have the checkbox checked to use a custom profile directory. Perhaps it is because the new profile doesn't have the Jetbrains extension added to it? Since the installer has to install the extension, how would you do that?

Thanks for the info so far.

0
Comment actions Permalink
I'd say that is a bit of pain for a developer to be honest. I tend to have a LOT of windows/tabs open in Chrome while I work.

Just make sure to uninstall Jetbrains Chrome extension from the profile you use for browsing (and not for debugging) - Idea will never connect to Chrome instance that doesn't have extension installed and enabled

Perhaps it is because the new profile doesn't have the Jetbrains extension added to it?


see above - profile that doesn't have extension enabled can't be used for debugging

Since the installer has to install the extension, how would you do that?


sorry, what installer are you talking about? Extension is installed from Chrome web store, just like all other Chrome extensions, no installers are required. See https://confluence.jetbrains.com/display/WI/Live+Edit#LiveEdit-InstallingGoogleChromeextension for instructions

0

Please sign in to leave a comment.