Can't type in editor window



I'm running the latest EAP (142.2887.3) on OS X and I've lost all keyboard input within the Editor and Project windows.

When I type, nothing is changed in the editor windows.  IntelliJ hasn't hung, its just mot accepting any keyboard input.

The problem goes away when I open the Preferences window and type in the search box at the top left.  It's as though this can get my cursor focus but the main editor window can't.

I've only seen this once on the latest EAP and can't replicate it.

Has anyone else seen this problem?



Do you have IdeaVim plug-in installed?


Unfortunately not.  Just a plain installation of IntelliJ with no additional plugins.


Dos it happen with JDK 1.8 bundled build?

Attach idea.log: .


And if you are on the custom JDK, can you please try the steps in IDEA-141583?

The behavior you are describing sounds like my bug, although I don't recall having IJ lock me out of the editor pane, just file dialogs, preference text inputs, etc.


I had the same problem. It goes away after I click the icon at top of the scroll bar. it happens frequently on windows 7/10, and occasionally on mac. my colleagues said they have experienced it too. (sorry for bad English)


EDIT: Managed to fix it for me for the time being: for some reason my workspace.xml file had the following:

<component name="IdeDocumentHistory">
<option name="CHANGED_PATHS"/>


as soon as this was changed to 

<component name="IdeDocumentHistory">
<option name="CHANGED_PATHS"><list></list>


the IDE started to accept edits to the files. 


Also, apologies, my version is not EAP, but this is what I was able find as representing the issue I am seeing.


Same issue, all files in one particular project are non-editable, other keyboard commands work, other projects seem fine.

Windows 7, IDEA 2016.2.5

The log shows a NPE:

2016-10-26 14:20:25,367 [ 151201] ERROR - llij.ide.plugins.PluginManager - null
at com.intellij.openapi.fileEditor.impl.IdeDocumentHistoryImpl.getChangedFiles(
at com.intellij.openapi.fileEditor.impl.NonProjectFileWritingAccessProvider.isWriteAccessAllowed(
at com.intellij.openapi.fileEditor.impl.NonProjectFileWritingAccessProvider.lambda$requestWriting$1(
at java.util.Spliterators$ArraySpliterator.forEachRemaining(
at com.intellij.openapi.fileEditor.impl.NonProjectFileWritingAccessProvider.requestWriting(
at com.intellij.openapi.vcs.readOnlyHandler.ReadonlyStatusHandlerImpl.ensureFilesWritable(
at com.intellij.openapi.vfs.ReadonlyStatusHandler.ensureFilesWritable(
at com.intellij.openapi.fileEditor.impl.FileDocumentManagerImpl.requestWriting(
at com.intellij.openapi.editor.actionSystem.TypedAction$DefaultRawHandler.lambda$execute$0(
at com.intellij.openapi.command.impl.CoreCommandProcessor.executeCommand(
at com.intellij.openapi.editor.actionSystem.TypedAction$DefaultRawHandler.execute(
at com.intellij.openapi.editor.actionSystem.TypedAction.actionPerformed(
at com.intellij.openapi.editor.impl.EditorImpl.processKeyTyped(
at com.intellij.openapi.editor.impl.EditorImpl.processKeyTyped(
at com.intellij.openapi.editor.impl.EditorImpl$7.keyTyped(
at java.awt.AWTEventMulticaster.keyTyped(



I'm also having this same problem in PhpStorm. Sometime changing to other window and typing in it fixes the problem.

PhpStorm 10.0.3 and Mac Os X 10.11.6.


Also happening on WebStorm 2016.3.2 (stable) with bundled JRE, using Windows 7.

But I noticed it happens some time after the TypeScript Service (built-in) is started, and when trying to create a new file (the name field does not get focus instantly).


I'm seeing the same issue for WebStorm 2016.3.2. I just installed it last week and have added no plugins so far.

The only thing that works for me is to quit the program and restart.


Switch to Oracle JDK 1.8 fix the problem.


PhpStorm 2016.3.2
Build #PS-163.10504.2, built on December 20, 2016
JRE: 1.8.0_101-b13 amd64
JVM: Java HotSpot(TM) 64-Bit Server VM by Oracle Corporation


Same problem..... it happens "random" sometime after 30min of use. ... sometimes after 10min. -> restart PHPStorm helps :(


I found that the error appears in cases where the date on the computer is set to past date. After the error appeared again, I set time to current and the bug disappeared. I could type again in the editor window.

IntelliJ IDEA 2016.3.5

Windows 7 x64

JRE: 1.8.0_101-b13


Same thing just happened to me. I was doing work just fine, and then I couldn't type at all in the Editor window or Apple + F2 to kill modules (or Ctrl + Option + D to restart debug on running modules). Had to restart the IDE, which sucks because I run modules in it which can mess up resources if they're not properly terminated.


IntelliJ IDEA 2017.1
Build #IU-171.3780.107, built on March 22, 2017
Licensed to ***
Subscription is active until October 5, 2017
JRE: 1.8.0_112-release-736-b13 x86_64
JVM: OpenJDK 64-Bit Server VM by JetBrains s.r.o
Mac OS X 10.12.4


Turn off  Vim Emulator from Tools in the intelliJ, like this picture:


Having same issue

IntelliJ IDEA 2017.1.1
Build #IC-171.4073.35, built on April 6, 2017
JRE: 1.8.0_121-b13 amd64
JVM: Java HotSpot(TM) 64-Bit Server VM by Oracle Corporation
Linux 3.13.0-116-generic

Have been having it since 2017.1, was not happening (as far as I know) in mid 2016

This is happening several times a day, have to restart IDE or I can't change any code.  Dialog boxes do not work, code editing does not work.  Hot keys and mouse works.


Thanks @Xericoder. This problem was killing me! 

I was facing this problem in Webstorm 2017.1.2 version on my Mac OS 10.x. I just have to click the icon at top of scroll bar!


I first noticed this in my phpstorm editor after updating to the 2017.1.3. I updated from 2016.x.x only because I wasn't able to copy and paste into the editor from another program. Now I can't type in characters like brackets, commas or even use the return the key. I also notice that a few of the dropdown menus are non responsive. I tried clicking on the eye icon at the top of the scroll bar and I'm not using a JDK (installed without it). What's going on ? 


This seems to happen whenever I hold a key down. No more keyboard input. However, I discovered that some keys give input if I hold them down, but no a-z keys. Characters I can get on repeat is: ;:_*'><!"#€%&/()=?. (and backspace)

Very strange. Does this apply to you guys as well ?


Happened same problem with RubyMine, I couldn't edit the file, it shows me 'search for' and searching file name in the project directory, happens so frequently, is there any solution?, I don't want to reboot RubyMine everytime.


I had the same issue with IntelliJ IDEA 2017. Removing one of the plugins and restarting IntelliJ resolved the problem.


Thanks @Ankit-Goyal clicking that little square fixed it!

I noticed mine would try and search the project tree when it wouldn't type in the editor

Edit: Still getting this issue unfortunately. And i'm not changing the system time at all as others have suggested.


Same problem here running IDEA 2017.2.4. I use ideaVim but turning it off has no affect. I switched Project ByteCode Version to 1.8 (was empty) and it started working again.


Seems that I have found an easy way how to reproduce this issue:

  1. Open IntelliJ
  2. Change system time to future
  3. Type, search etc. in IntelliJ
  4. Switch time back to current date
  5. Try typing, searching etc. in IntelliJ.

At that moment keyboard focus is getting stuck in one of the IntelliJ panels.


In my case this happened since I accidentally changed the keyboard mapping. By reseting the keyboard map to the default keymap I am now able to edit files in the editor pane. 

Many thanks



It was the effing Vim mode for me.

@S165235 You sir are the God-emperor of mankind!


@Veggen+intellij Thanks, glad it helped you :) 


I worked out that it was because they've added the keyboard shortcut cmd+opt+v which I often accidentally hit - it activates VIM emulator mode!


Got same issue. Vim Emulator not installed.

Solution suggested by @Ankit-Goyal worked for me.


UPD: worked only once :(


Please sign in to leave a comment.