Can't type in editor window



I'm running the latest EAP (142.2887.3) on OS X and I've lost all keyboard input within the Editor and Project windows.

When I type, nothing is changed in the editor windows.  IntelliJ hasn't hung, its just mot accepting any keyboard input.

The problem goes away when I open the Preferences window and type in the search box at the top left.  It's as though this can get my cursor focus but the main editor window can't.

I've only seen this once on the latest EAP and can't replicate it.

Has anyone else seen this problem?



Turn off  Vim Emulator from Tools in the intelliJ, like this picture:


I had the same problem. It goes away after I click the icon at top of the scroll bar. it happens frequently on windows 7/10, and occasionally on mac. my colleagues said they have experienced it too. (sorry for bad English)


Do you have IdeaVim plug-in installed?


This seems to happen whenever I hold a key down. No more keyboard input. However, I discovered that some keys give input if I hold them down, but no a-z keys. Characters I can get on repeat is: ;:_*'><!"#€%&/()=?. (and backspace)

Very strange. Does this apply to you guys as well ?


I found that the error appears in cases where the date on the computer is set to past date. After the error appeared again, I set time to current and the bug disappeared. I could type again in the editor window.

IntelliJ IDEA 2016.3.5

Windows 7 x64

JRE: 1.8.0_101-b13


Thanks @Xericoder. This problem was killing me! 

I was facing this problem in Webstorm 2017.1.2 version on my Mac OS 10.x. I just have to click the icon at top of scroll bar!


Its funny people keep assuming the VIM Plugin is even installed and refers to this solution when the reporter (David) clearly stated he hadn't this plugin installed.


It's also interesting that, after three years, people are still having this issues and the only solutions (depending on the configuration) is to disable a plugin which might be needed or to fiddle with the Java runtime which not everyone feels or know how to do.


JetBrains, it might be time to have the issue fixed from your side instead of relying on workarounds which don't even always work.


This happens to me on macOS.
When I hold down a letter key that has variants like 'a' macos gives you options so you could write 'á' for example.
This then breaks the writing in WebStorm. Currently I can fix this by swapping my keyboard input source which I have bound to a keyboard shortcut.


EDIT: Managed to fix it for me for the time being: for some reason my workspace.xml file had the following:

<component name="IdeDocumentHistory">
<option name="CHANGED_PATHS"/>


as soon as this was changed to 

<component name="IdeDocumentHistory">
<option name="CHANGED_PATHS"><list></list>


the IDE started to accept edits to the files. 


Also, apologies, my version is not EAP, but this is what I was able find as representing the issue I am seeing.


Same issue, all files in one particular project are non-editable, other keyboard commands work, other projects seem fine.

Windows 7, IDEA 2016.2.5

The log shows a NPE:

2016-10-26 14:20:25,367 [ 151201] ERROR - llij.ide.plugins.PluginManager - null
at com.intellij.openapi.fileEditor.impl.IdeDocumentHistoryImpl.getChangedFiles(
at com.intellij.openapi.fileEditor.impl.NonProjectFileWritingAccessProvider.isWriteAccessAllowed(
at com.intellij.openapi.fileEditor.impl.NonProjectFileWritingAccessProvider.lambda$requestWriting$1(
at java.util.Spliterators$ArraySpliterator.forEachRemaining(
at com.intellij.openapi.fileEditor.impl.NonProjectFileWritingAccessProvider.requestWriting(
at com.intellij.openapi.vcs.readOnlyHandler.ReadonlyStatusHandlerImpl.ensureFilesWritable(
at com.intellij.openapi.vfs.ReadonlyStatusHandler.ensureFilesWritable(
at com.intellij.openapi.fileEditor.impl.FileDocumentManagerImpl.requestWriting(
at com.intellij.openapi.editor.actionSystem.TypedAction$DefaultRawHandler.lambda$execute$0(
at com.intellij.openapi.command.impl.CoreCommandProcessor.executeCommand(
at com.intellij.openapi.editor.actionSystem.TypedAction$DefaultRawHandler.execute(
at com.intellij.openapi.editor.actionSystem.TypedAction.actionPerformed(
at com.intellij.openapi.editor.impl.EditorImpl.processKeyTyped(
at com.intellij.openapi.editor.impl.EditorImpl.processKeyTyped(
at com.intellij.openapi.editor.impl.EditorImpl$7.keyTyped(
at java.awt.AWTEventMulticaster.keyTyped(



Seems that I have found an easy way how to reproduce this issue:

  1. Open IntelliJ
  2. Change system time to future
  3. Type, search etc. in IntelliJ
  4. Switch time back to current date
  5. Try typing, searching etc. in IntelliJ.

At that moment keyboard focus is getting stuck in one of the IntelliJ panels.


Switch to Oracle JDK 1.8 fix the problem.


Having same issue

IntelliJ IDEA 2017.1.1
Build #IC-171.4073.35, built on April 6, 2017
JRE: 1.8.0_121-b13 amd64
JVM: Java HotSpot(TM) 64-Bit Server VM by Oracle Corporation
Linux 3.13.0-116-generic

Have been having it since 2017.1, was not happening (as far as I know) in mid 2016

This is happening several times a day, have to restart IDE or I can't change any code.  Dialog boxes do not work, code editing does not work.  Hot keys and mouse works.


I worked out that it was because they've added the keyboard shortcut cmd+opt+v which I often accidentally hit - it activates VIM emulator mode!


I have this issue and i don't have the plugin vim.

I'm using Ubuntu 18.04, and 17.10 and this is so frustrating.

Randomly it stops to accept keyboard commands, to "fix" i have to close and open again.




Rubymine 2018.2. It is back again. I need to restart the IDE several times a day. 


I'm seeing the same issue for WebStorm 2016.3.2. I just installed it last week and have added no plugins so far.

The only thing that works for me is to quit the program and restart.


Thanks @Ankit-Goyal clicking that little square fixed it!

I noticed mine would try and search the project tree when it wouldn't type in the editor

Edit: Still getting this issue unfortunately. And i'm not changing the system time at all as others have suggested.


@Serge Baranov, reproduced with 2018.1.3

I will create report as you asked


Why does this need VIM mode, thats an overkill.

And why cant it be 'intelligent' enough to tell us when something is missing instead of dumbly doing NOTHING !


@BrixSat Could you please provide idea.log after reproducing a problem.


It happens to me sevaral times a day on Rider 2018.2.3, running on ubuntu 18.04.


In MacOS this happens when character accent is enabled and triggered. If you do not use character accent type this in terminal and it will stop happening

defaults write -g ApplePressAndHoldEnabled -bool false

i change the system time to the last time for testing , so it's happened to me

firstly  i thought it's worst by vim plugin,   i  turn on/off for much times but no helps.

that's ok immediately when i change the system time  correctly.


I can't edit any of html files, once i open any html file, the keyboard do nothing and i have this bug with html files and text files, i tried everything to fix it and i ended to use another idea for html files, works great! 

Arseniy Nisnevich


You are facing one of a plenty focus related problems. We will need more details to recreate and fix it. Once you find out when this problem occurs, please, file a new issue and describe steps to reproduce:

Arseniy Nisnevich


This issue was fixed:

However, the fix is not bundled with PyCharm yet. You can switch boot JDK to the following build:

See instruction on how to switch:

Arseniy Nisnevich


There is a known issue on macOS when focus is lost after showing different dialogs:

Could you try applying a workaround from the header in issue description?


This was happening to me in PHPStorm. It was the "File Watchers" plugin. I deactivated that, then restarted PHPStorm. Then I set it back to active bc it is useful, and when I restarted the second time, all was good. There must have been a configuration issue with the plugin which is reset when de/activating


Unfortunately not.  Just a plain installation of IntelliJ with no additional plugins.


Please sign in to leave a comment.