Scala Plugin Not Recognized?

No Scala Files are recognized after pulling down the latest pre-built IDEA 15 EAP w/ JDK8 for OS X (v.142.2670.3) and installing the Scala plugin (released today - v.0.41.915).

Invalidating the caches and restarting did no good.

Has anyone gotten Scala and ScalaTest working with the latest IDEA 15 EAP on OS X?

In addition, when upgrading from IDEA 14, wouldn't the user expect to have the latest versions of the same plugins automatically installed? In this version, neither the SBT, nor Scala plugins were installed.

4 comments
Comment actions Permalink

Where did you find Scala plugin v. 0.41.915? Actual version for IDEA 15 is 1.6.1.

Best regards,
Alexander Podkhalyuzin.

0
Comment actions Permalink

That is the version of the Plugin installed using the Plugins Dialog. It sounds like there's a disconnect between what is offered and the latest version, though.

That was the issue. Thank you.
Fixed by downloading the 1.6.1 Scala plugin from: https://plugins.jetbrains.com/plugin/?id=1347 and installing it from disk.

Could IDEA 15 possibly implement a feature that automatically installs the correct/latest version of the Scala plugin (including SBT support) when a project is opened with Scala files?

(This could be useful for other support, as well, such as XML, JavaScript, Python, etc.)

0
Comment actions Permalink

I'll ask guy from IntelliJ team to check problem with Scala plugin downloading. Thank you for your report.

Best regards,
Alexander Podkhalyzuin.

0
Comment actions Permalink

Please check Scala plugin channel, if it's EAP or Release, probably EAP or Nighlty case causing this bug. You can find it under Settings -> Languages... -> Scala -> Updates.

Best regards,
Alexander Podkhalyuzin.

0

Please sign in to leave a comment.