Intellij 14 (UE), GWT SuperDevMode, NoServer

Hi,

I saw the blog post on using GWT SuperDevMode with Intellij 14. Our situation is slightly different in that we cannot use the built-in Jetty to run our application, so we need to pass the "-noserver" option to GWT. When we do this then everything seems to be running correctly... I have Tomcat running on port 8080, the GWT codeserver starts successfully, and the IntelliJ Javascript debugger is connected to my Chrome tab (I can see the javascript console output in the Intellij javascript console). But the breakpoints in my GWT code do not have the red "tick" beside them, just a red circle, and the breakpoints are not activated when the code is executed.

What are we doing wrong?

We are using GWT 2.7.0, IntelliJ 14.0.2. Any other version numbers you'd like to know?

Kind regards,

Gareth

1 comment
Comment actions Permalink

Gareth, did you ever figure this out?

For me, it's not even working with the default options (embedded server).

GWT codeserver starts successfully, and the IntelliJ Javascript debugger is connected to my Chrome tab (I can see the javascript console output in the Intellij javascript console). But the breakpoints in my GWT code do not have the red "tick" beside them, just a red circle, and the breakpoints are not activated when the code is executed.

Yeah, same. I feel like I'm so close to a great dev experience. Can anyone contribute here?

0

Please sign in to leave a comment.