36 comments
Comment actions Permalink

I was facing these issues in the company network and we have a SSL proxy. I've received company SSL root certificates from the devops team and I installed those in Intellij JDK cacerts and the issue is gone.

The bug here is that even after adding an exception using the pop-up in another cacerts. The pop-up keeps recurring it doesn't seem to use the newly created cacerts.

0
Comment actions Permalink

Still having this issue 2/27/19 on version 2018.3.3 (Ultimate Edition). The longer I leave the IDE open, the more times I have to hit accept.

0
Comment actions Permalink

Our organization uses SSL MITM proxy and I had to add intermediate SSL certificates to cacerts. Just so that it helps someone.

0
Comment actions Permalink

You can vote for https://youtrack.jetbrains.com/issue/IDEA-173599 request - to make the certificate management easier in IDE.

0
Comment actions Permalink

I was having the same issue here. I discovered that I had a previous SSL CA cert setting in the custom VM options. That CA Cert bundle was pointing to the Oracle Java 8 package from my Ubuntu OS, which has now become outdated. So it started firing warnings.

I've fixed it by removing that setting, it's now working properly.

0
Comment actions Permalink

The solution previously provided by Adam Labi (https://www.jetbrains.com/help/idea/settings-tools-server-certificates.html?_ga=2.29019964.1863818505.1565794026-340532234.1561578039) resolved this issue for me.

But I wanted to point out; along the same lines of the proxy related comment made by Andrey Dernov; that my problem was environmental because it only happened while connected to the network at work. If I opened the IDE at home (on the same laptop), the SSH certificate messages wouldn't appear.

I was able to confirm with our IT Security team and learned that our web filtering proxies were the root cause of my problem, and hopefully, this bit of information might help shed some light on some of the issues being experienced by others.

0

Please sign in to leave a comment.