Jetty Web-App - Error running UI: Address localhost:1099

I used to use IDEA to debug my web-app, no problem. Recently, a mess-up happened when trying to upgrade KUbuntu from 14.04 LTS and I ended-up having to reinstall my entire OS from scratch. Now I am running KUbuntu 15.10, fresh install.

Debugging was working fine for a few hours, until either some update or the installation of VirtualBox 5.10 (using Muon Discover) happened and the running or debugging the same project configuration started yielding:
       Error running UI: Address localhost:1099 is already in use

Following advice obtained with several Google searches, I tried:

1. 1099 is the port mentioned for the JMX module in the run/debug configuration. If I change the port, the error message changes accordingly.

2. Doing netstat and/or lsof, this port is never being monitored by any process at all. My firewall is off, IPV6 is disabled, and I've disabled every IDEA plugin I can think of.

3. Editing /etc/hosts

Nothing is working. The log at /home/userName/.IntelliJIdea14/system/log does not show any error.

I really hope someone here can help me sniff-out the cause.
Thanks

### Platform:
# Distributor ID: Ubuntu
# Description:    Ubuntu 15.10
# Release:        15.10
# Codename:       wily
#
# IntelliJ IDEA 14.1.5 Ultimate (licensed)
#
# java version "1.8.0_66"                                                                                                                                                                       
# Java(TM) SE Runtime Environment (build 1.8.0_66-b17)                                                                                                                                          
# Java HotSpot(TM) 64-Bit Server VM (build 25.66-b17, mixed mode)

2 comments
Comment actions Permalink
What is your Jetty version?

Please provide:
1) screenshot of your run configuration
2) does the run configuration produce some textual output before fail? provide the complete textual output produced if any

Thanks
0
Comment actions Permalink

The problem was found and solved:
Setting-up the OS for company domains, nsswitch.conf got corrupted such that localhost could no longer be resolved at the application layer. This explains why changing the port had no effect.

Closing.

0

Please sign in to leave a comment.