Windows UNC Paths in 141.175 (RC)

I've just updated to the 14.1 RC, but when I try to open my project - which is on a UNC mounted drive IDEA tells me none of the modules can be located, but I can see all files in the correct places from explorer. This project is a little unusual, have project files in one place and other UNC folders as addtional source bases or modules - its not a one folder thing it spiders different parts of a large UNC filesystem.

When I try to open the UNC path from IDEA project open it seems I can on longer enter and browse UNC paths? IntelliJ appears to assume //server//path means use my users home directory? A few times it opened my home directory as a project then chocked trying to index 50GB files within and had to kill the IDEA process as IDEA was unresponsive.

Has something critical changed in the RC release towards UNC support? project was working fine yesterday with the previous 14.1 EAP build.

8 comments
Comment actions Permalink

Seems likes there's two issues. The .idea/modules.xml file has messed up all the UNC paths adding all kinds of nonsense directory traversals. If I fix these manually I can open the project, but IDEA immediatly corrupts modules.xml paths again so I expect I'll have to re-edit to open again later.

Also I couldn't browse UNC paths at all, in the file browser \\server is assumed to be my my users home dir on the C:/ drive. Hitting enter opens the folder - it doesn't browse to the entered path? and leave me to hit [Open] or [OK] to confirm the directory. Can't remember if previous version was the same and I just typed the UNC path without browsing.

0
Comment actions Permalink

UNC paths are not supported: https://youtrack.jetbrains.com/issue/IDEA-123273 .

As a workaround assign a letter to the network drive.

0
Comment actions Permalink

If its not supported how about stopping users for creating projects from them in the first place? Warning this is not supported?

I cannot assign a drive letter to the root of the UNC drive which I'd need to do as this project spans multiple root paths. I don't want to create a new project either my main reason for doing this in IntelliJ was the project lacks VCS support (external customer) so I was depedning on the Local VCS history of IDEA, so by changing any module paths - I'd loose all local history?

The major problem with IDEA appears to be with the excaping of paths in modules.xml + the file browsers UX is pretty unhelpful.

0
Comment actions Permalink

Ok I've mapped several drive letters for each UNC mount point and surrendered my local history with a new project.

So each addtional drive letter (except the project module itself) is added as a content root to the project, just the drive letter so the content root appears like 'O:'. Think I added them like 'O:/' but IDEA just shows 'O:'.

But now I find I cannot add or remove any files, IDEA keeps saying: Cannot modify as read-only directory 'O:/'.

The folders aren't read-only. In explorer I can add and remove without problems to same drive letter. Same user, no tricky ACL or Group security set on the UNC folders so far as I can tell. I can edit the files that already exist in the drive through IDEA but cannot add or remove any new files to same location?

The lock icon in the bottom right corner is unlocked, thats the file/folder lock indicator isn't it?

0
Comment actions Permalink

hmm on further investigation the read-only message only appears for the root folders (i.e. O:/). I can add files and folders via IDEA to any folders under this, but not the root folder itself. Guess where all our project files are? (yeah this isn't a Java project - otherwise I'd be using Linux).

0
Comment actions Permalink

Run into more problems with drive mapped folders, seems the file monitoring isn't working well. Have to keep synchronizing manually to see changes made externally to files & folders (like using eclipse). It's pretty painful.

0
Comment actions Permalink

You can add -Didea.filewatcher.disabled=true into .vmoptions (https://intellij-support.jetbrains.com/entries/23395793).

Native monitoring is not supported for network dirves (OS limitation).

Using network drvies is not recommended, consider keeping the files locally and use Deployment or VCS for syncrhonization.

0
Comment actions Permalink

Thats what I added to that ticket. In this case it was work for an external client and I had no choice or control over the enviroment or location of the files.

Their lack of VCS is why I tried to use IDEA.

0

Please sign in to leave a comment.