14.1 EAP Mac Java 1.8u40 custom Huge font


I just quickly tried the Mac 14.1 eap with the custom java 1.8 and for some reason the editor, along with some other parts of the ui had huge fonts. I thought it was the presentation mode, but it was off and the view/tool buttons were huge as well as the dialogs. Though the project view was opened and had the normal size font. Menu was normal also. See attached screenshots. I also tried switching the appearance to the default theme, but it looked the same and didn't update the editor directly (still dark themed).

So I'll stick with the 14 release for now...

Kind Regards,

Screen Shot 2015-02-04 at 09.26.27.png

You can try the following steps.
1. switch Resolution to 'Default for display' in Displays System Preferences.
2. launch IDEA 14.1 EAP
3. switch Resolution to 'Scaled', then select which resolution you want.


Hi Alex,

Thanks for the suggestion. Just tried it and after switching to the scaled display, IntelliJ is indeed back to it's normal look. Though every restart of IntelliJ requires to adjust it again...



FYI: I'm currently running IntelliJ 14.0.3 with Oracle Java 1.8.0_05-b13 x86_64 which seems to run fine. I also tried to run the EAP version without the custom build java and tried to update the info.plist as I did with 14.0.3, but that gave the same problem as the one with the custom java.


Please sign in to leave a comment.