High DPI Support on Linux in IntelliJ 15.0.1 (idea-IU-143.382.35)

So I used IntellJ 14 with the vm options -Dis.hidpi=true. According the the following blog post, IntelliJ 15 has native high dpi support for UHD/4k monitors:

http://blog.jetbrains.com/idea/2015/07/intellij-idea-15-eap-comes-with-true-hidpi-support-for-windows-and-linux/

So I booted up IntelliJ 15 today and everything is super tiny again. I don't see anything in settings for either "dpi" or "scaling." So the automatic high-dpi obviously isn't working. How do I set it manually? How is IntelliJ supose to auot-detect it? I'm on Gentoo Linux running the i3 window manager.

3 comments
Comment actions Permalink

Please, look into https://youtrack.jetbrains.com/issue/IDEA-144730 where DPI issues on Linux were discussed. Namely, you should evidently specify your DPI for X11 (or define it in the appropriate X11 config file) via "xrandr --dpi <dpi>". Check it with "xdpyinfo | grep resolution". This is the DPI value read by IDEA. Also, you don't have to set "hidpi=true", it's true by default.

0
Comment actions Permalink

Okay. So I ran the following (it was set to 96x96)

    xrandr --output eDP1 --dpi 192

Now the splash screen is the correct size (double its previous size), but when the IDE window pulls up, everything is tiny again. In fact, as the Splash Screen is coming up, it switches from double its size back down to half its size, almost as if it's starting out in highdpi mode and then some other check is flipping it back down.

0
Comment actions Permalink

Ok, your IDEA build version doesn't seem to contain the HiDPI fix for Linux (IDEA-144730). Please, try the latest EAP to see if the problem is resolved on your side:

https://confluence.jetbrains.com/display/IDEADEV/IDEA+15+EAP

(Also, please, make sure you have default font settings in Settings->Appearance & Behavior->Appearance, "Override default fonts"). The splash screen issue you described was fixed as well (IDEA-144468, IDEA-143450). It should be in EAP by the above link.

0

Please sign in to leave a comment.