How do I prevent IntelliJ IDEA 15 from auto inserting double pound signs (##)?

Hello fellow devs,

I'm using IntelliJ Idea Ultimate 15.0.01 for CFML (ColdFusion) application development and for some reason every time I type a pound sign, the program automatically inserts a second one.

For example, if I type: "welcome back #firstName#" the program will display this instead: "welcome back ##firstName##".

I've searched through the settings/preference but haven't found a checkbox to disable this feature.  Any help would be most appreciated.

Thanks!



Attachment(s):
double_pound.jpg
2 comments
Comment actions Permalink

Hi,

This feature cannot be disabled.

Please vote for https://youtrack.jetbrains.com/issue/IDEA-148357.

0
Comment actions Permalink

UPDATE:

You can add this to your idea.properties file:

#-----------------------------------------------------------------------
# Change to 'false' if you want to disable auto insertion of pound signs
#-----------------------------------------------------------------------
idea.cfml.insert.pair.pound=false

0

Please sign in to leave a comment.