Weirdness with optimize imports in latest EAP

I have a class I pulled in from a colleague's work that has a number of unused import references. Normally I'd just hit Alt-Enter and optimize the imports and be done with it (I don't have optimize on the fly enabled because this causes a great deal of churn in our code repo: eventually we'll optimize everything in a single pass but it's not feasible at the moment).

However, in the latest EAP (134-1445), the Optimize action isn't an option. Instead, only Enable optimize on the fly and Create Test are the only actions available. So I then managed to enable optimize on the fly since I had expected that to just be the manual optimize choice. The interesting thing here is that it's not optimizing on the fly, i.e. my unused imports are still just sitting there, but there's still no action that I can use to optimize the imports.

1 comment
Comment actions Permalink

Hi,

Sorry for long answer. There is an issue about that: http://youtrack.jetbrains.com/issue/IDEA-122234. Fix will be delivered in IDEA 13.1.2

0

Please sign in to leave a comment.