TFS connection time-outs

Dear Sir/Madam,

I'm having difficulty connecting to our TFS 2012 server via IntelliJ Ultimate 14.1.4. I enabled the 'httpclient.wire' loggin in \bin\log.xml and see the following:

2015-11-02 08:25:22,184 [ 245148]   INFO - .httpclient.HttpMethodDirector - I/O exception (java.net.ConnectException) caught when processing request: Connection timed out: connect
2015-11-02 08:25:22,184 [ 245148]   INFO - .httpclient.HttpMethodDirector - Retrying request
2015-11-02 08:25:43,237 [ 266201]   INFO - .httpclient.HttpMethodDirector - I/O exception (java.net.ConnectException) caught when processing request: Connection timed out: connect
2015-11-02 08:25:43,237 [ 266201]   INFO - .httpclient.HttpMethodDirector - Retrying request
2015-11-02 08:26:04,318 [ 287282]   INFO - .httpclient.HttpMethodDirector - I/O exception (java.net.ConnectException) caught when processing request: Connection timed out: connect
2015-11-02 08:26:04,318 [ 287282]   INFO - .httpclient.HttpMethodDirector - Retrying request


I've tried every possible combination in the 'Add Team Foundation Server' dialog (NTLM (system credentials)/NTLM/Alternate).

I don't have any issues connecting with VS 2012 or via the web browser (Chrome).

One of the main reasons we purchased the Ultimate edition of IntelliJ is that it has TFS 2012 support, but at the moment we can't use it, which is a shame.

There are no firewalls (network, nor Windows) enabled/present.

Any thoughts?

Perhaps there is some other logging I can enable to troubleshoot this issue.

Thanks in advance.
2 comments
Comment actions Permalink

Could you please configure debug logs (Help -> Configure Debug Log Settings) for "org.apache.commons.httpclient", "httpclient.wire" and "org.jetbrains.tfsIntegration" categories and attach log files to this issue? (you could set "Visible to:" to "idea-developers")

0
Comment actions Permalink

We sorted this out yesterday, but I didn't get a chance to report back here yet. Anyway, the issue was related to the proxy settings. IntelliJ grabbed the 'Windows/IE' settings (it seemed) by default, which caused the connection timeout issues. We since corrected this to 'No proxy' (in the 'System Settings\HTTP Proxy' section) and all is good.

Thanks for the follow up.

0

Please sign in to leave a comment.