JavaFX Packager Error

Answered

Hi,

When I try to build an artifact of a JavaFX project, I get the following error:

Error:Java FX Packager:
BUILD FAILED
Error reading project file C:\Users\Jürgen\.IdeaIC13\system\compile-server\_temp_\build7645261974522649442.xml: Ungültiges Byte 1 von 1-Byte-UTF-8-Sequenz.

Total time: 0 seconds

Error:Java FX Packager: Buildfile: C:\Users\Jürgen\.IdeaIC13\system\compile-server\_temp_\build7645261974522649442.xml
Error:Java FX Packager: fx:deploy task has failed.



When running the project from the IDE, everything is fine.



Best Regards
Jürgen
5 comments
Comment actions Permalink

Same thing here. In my case this only happens when I use the Ultimate Edition. The Community Edition I use at home does alright.

Information:19.03.2015 17:07 - Compilation completed with 3 errors and 0 warnings in 1 sec Error:Java FX Packager: BUILD FAILED Error reading project file C:\Users\Sönke Greve\.IntelliJIdea14\system\compile-server\_temp_\build0.xml: Ungültiges Byte 2 von 4-Byte-UTF-8-Sequenz. Total time: 0 seconds Error:Java FX Packager: Buildfile: C:\Users\Sönke Greve\.IntelliJIdea14\system\compile-server\_temp_\build0.xml Error:Java FX Packager: fx:deploy task has failed.


Was there any solution to this?

0
Comment actions Permalink

Hi, No solution or response so far. Maybe the version of the community edition and Ultimate one you use differ

At the moment I ended up using e(fx)clipse for building my native binaries, and IntelliJ for development. If you find any solution, pls. Let me and others know.

0
Comment actions Permalink

Thx 4 the response.

Both versions are the current releases. I should probably try the Ultimate Edition on another PC just to narrow down the number of suspects.

0
Comment actions Permalink

So I finally found the solution. Apparently the bits creating the package have a problem when there's an "Umlaut" in the folder path, as isn't capable of converting windows-encoding to UTF at some point.

Just move the IntelliJ config folder (.IntellijIdea14 in my case) somewhere without special characters in the path und you should be able to build the artifacts.

You can find a short description of how to do it in the last 5 lines hiere:
https://www.jetbrains.com/idea/help/project-and-ide-settings.html#d1690895e155

I figured it out when I saw you also have an Umlaut in your name. German Problems :^O

0
Comment actions Permalink

In my case, I went to project structure > artifacts > JavaFX (tab) > scroll down and make sure the Native Bundle is either set to "none" or ".exe".

If you set it to "all", you'll get an error because Windows does not know how to package Linux .deb files. 

0

Please sign in to leave a comment.