13 Beta and Gradle

Currently getting "Bad version number in .class file" when I try to import a Gradle project.
Caused by: java.lang.UnsupportedClassVersionError: Bad version number in .class file

I've tried with both Gradle 1.9rc3 (using both "absolute" and "default gradle wrapper" options) and Gradle 1.8 (only absolute option, don't want to regress my project to 1.8).

To be honest though - I'm not too concerned about the import not working.
What I'm more concerned about is how to get rid of the "module is not backed by gradle" error when running with a generated project.

I normally generate the IDEA project files using the gradle plugin.  This works fine with IDEA 12, the first time your try to run a task it prompts you to configure gradle (and later suggests configuring groovy).

With 13 Beta - when I generate a clean set of IDEA files and then open the project - when I try to run a task it just says "module is not back by gradle" - with no suggestion as how to fix it.

Any suggestions for how I can fix the "module is not backed by gradle" error when I run a task?

P.S. when I say "run a task" - I'm referring to opening the .gradle file, navigating to the task and pressing ctrl-shift-F10.


Please sign in to leave a comment.