Cannot create Grails app with build 839

I have have tried to create a  Grails 2.3.1 project with build 839 and it doesn't - but I may not have created a Grails project recently so I'm not too sure how previous EAPs may have done.


I click on Create New Project and on the next window I highlight Grails on the left (in fact it was already selected), enter a project name on the right, correct the SDK (I've just updated Java - and have already checked that it worked with existing Grails projects in IDEA 839). I note the comment about 'Grails modules are used...' in the description box and press Next (this screen is identical to the 12.1.6 screen). The next screen is different, it says 'Please select the desired technologies' whereas previously the next screen would have simply been to select the Grails SDK.  The 'Please select the desired technologies...' screen does appear in IDEA 12.1.6 when I just want a Java project.

It seems that build 839 doesn't recognise the Grails selection and then takes the user into a Java-related process from which I can find no way of creating a Grails application.

I did look at the options and noticed that under 'Spring' it does list the Grails and Griffon SDKs that I have (under 'Use Library') but even if I select the appropriate Grails library the project is still taken as a Java project.

graham
1 comment

I see that this is now working with build 947

graham

0

Please sign in to leave a comment.