ssh forwarding doesn't work in terminal/console of deployment configured servers - get prompted for git password

I work locally and use the deployment servers to upload files and ssh to the machine.
when i enter shh terminal/run external tool to try to pull from git on the remote server - i get prompted for password.

*  in my ssh config i have:
ForwardAgent  yes

** ssh to the machine through the ubuntu terminal work as expected (no password prompt when trying to pull on remote server)

I would appreciate any help in this matter.
Thanks
5 comments
Comment actions Permalink

Hi Eli,

"when i enter shh terminal" - do you mean the Terminal tool window in IntelliJ IDEA? If yes, what is the shell path (check IDEA Settings | Terminal).

0
Comment actions Permalink

1. yes
2. shell path is: /bin/bash
3. it also happens in console of external tools

0
Comment actions Permalink

> 3. it also happens in console of external tools

Could you please clarify, what console are you referring to? Which external tools are you using?

0
Comment actions Permalink

a.this is the external tools
b+c.when the console is checkbox is checked, a small window will be opened, same as when you run tomcat server, java main files etc...



Attachment(s):
a.png
b.png
c.png
0

Please sign in to leave a comment.