Cardea (was Leda) EAP support for PHP (soon), Ruby (ok), and Python ETA (soon)?

The current Leda build UI 120.11 doesn't support PHP, Ruby, or Python. Is there an ETA on when those might be made compatible?

Thanks much!

22 comments
Comment actions Permalink

The Ruby plugiin will be available very soon. The Python plugin will most likely be available in 4-6 weeks. For the PHP plugin, I personally have no idea; hopefully some of my colleagues will answer.

0
Comment actions Permalink

It will be made available along with PhpStorm 5 EAP start - in about a week.

0
Comment actions Permalink

Thanks much Alexey. Just checking in on this as I won't be able to try Leda until these languages work. Looking forward to it!

Message was edited by: Michael Wills to fix typo in Alexey's name

0
Comment actions Permalink

I see that PHPStorm/Webstorm EAP 5 has started. It'll be another few days yet before the plugin is updated for Leda then, correct? Looking forward to it!

[edit]I see 120.305 does not support the other language plugins yet. Perhaps a couple of weeks out then?

0
Comment actions Permalink

Right with next EAP - supposedly Aug 6th.

0
Comment actions Permalink

It took a little longer but I like the PHP support I see in the latest EAP from today. Looking forward to Python, Ruby, etc.

Thanks!

0
Comment actions Permalink

Well, the PS EAP build was on the hold while we addressed some nasty bugs :)
EAP has an alpha status but it still needs some decent quality if we want people to actually use it - and we do.

0
Comment actions Permalink

I agree. I have been doing production work with EAPs (with versioned files of course!) right when the first EAP of PHPStorm after 1.x was released. Now that I use IntelliJ I do the same. :) I just have to wait until more languages are updated to get more use in. I am enjoying this new middle matching. It's speedy so far and even nicer to hop around the project!

0
Comment actions Permalink

Now I just await Ruby and Python. ;)

0
Comment actions Permalink

Just checking in for progress on Python and Ruby. Thanks!

0
Comment actions Permalink

Just checking in to see if there has been progress in this area. A bit jealous at the improvements I see for other languages but not for these languages. :D

0
Comment actions Permalink

*bump*

Just wondering if there is an ETA as I believe we as users of these languages can't review and test these languages yet.

Thanks!

0
Comment actions Permalink

Just checking in on Python support. Has there been any news?

Thanks!

0
Comment actions Permalink

The Python plugin is planned to be released next week.

0
Comment actions Permalink

Awesome. Thanks for the update! I should be able to move to Leda once that is out.

0
Comment actions Permalink

Installing and starting Leda EAP with the PHP plugin installed results in the following error being repeated over and over again in the Event log.  Is PHP support for Lead EAP ready yet?

11:22:05 AM NoClassDefFoundError: update failed for AnAction with ID=PhpListenDebugAction: Could not initialize class com.jetbrains.php.PhpIcons

0
Comment actions Permalink

http://blogs.jetbrains.com/idea/2012/11/intellij-idea-12-eap-122813-with-vaadin-and-drools-support/#comment-324420

On 11/18/2012 8:27 PM, Keith Wedinger wrote:

Installing and starting Leda EAP with the PHP plugin installed results in the following error being repeated over and over again in the Event log.  Is PHP support for Lead EAP ready yet?

>

11:22:05 AM NoClassDefFoundError: update failed for AnAction with ID=PhpListenDebugAction: Could not initialize class com.jetbrains.php.PhpIcons

>

---
Original message URL: http://devnet.jetbrains.net/message/5472150#5472150

>

0
Comment actions Permalink

Looks like they are all out now!

PHP's latest build at 2012-11-21
http://plugins.intellij.net/plugin?pr=&pluginId=6610

Ruby latest build at 2012-11-15
http://plugins.intellij.net/plugin?pr=&pluginId=1293

Python latest build at 2012-11-22
http://plugins.intellij.net/plugin?pr=&pluginId=631

Now I just need a safe time to launch and test Leda with these. Looking forward to it.

Thanks!

0
Comment actions Permalink

Unfortunately, now that LEDA is a 123 version, the ruby plugin is again no longer available :_|

0
Comment actions Permalink

Ah! Good catch! OK so Ruby is off the table again. :(

But hopefully available in a week

http://devnet.jetbrains.net/message/5472542#5472542

0
Comment actions Permalink

PHP looks good, and Python has been updated (haven't tested it yet), but Ruby is hopefully soon. But there have been two EAP updates(!). Was that the fastest back to back EAP release cycle?!

So any word on Ruby then?

0

Please sign in to leave a comment.