OSX - Merge dialog gets into unresolvable modal state, requires Force Quit

Here's what happens:

1. I'm in the Resolve Conflicts dialog, with a few files that have conflicts.
2. I choose "Merge" on one of the files.
3. I manually resolve the conflicts by clicking the arrows to merge left and merge right.
4. Once all items are merged, for a split second I see a confirmation pop up to Continue or Save and Finish.
5. I'm immediately switched back to the Resolve Conflicts dialog, and that confirmation pop up is nowhere to be found -- not on the Resolve Conflicts dialog, not on the Merge dialog, not anywhere. At this point, the Merge dialog is blocked (I can't click on anything), and because it's a modal, my whole project is blocked. I've tried all sorts of things to resolve the modal, but I can't. The only way I can escape is to Force Quit the whole IDE, which, as you can imagine, is quite frustrating.

Attached is a screenshot of the split second I see the confirmation popup, before it disappears and I'm stuck. As you can see the confimation seems to be attached to something wrongly. I also have a video of the whole thing if that would help.

This happens alot, and consistently when it does (restarting IntelliJ IDEA repeats the steps above over and over, to the point that I simply cannot perform a branch merge and have to get a colleage to do it for me), but it doesn't happen all the time. I haven't figured out why it happens.

I'm using OSX with Git. I am using a Macbook Pro with 3 external monitors. I use IntelliJ IDEA exclusively on my main external monitor.

Any ideas? Thanks.
-Aaron



Attachment(s):
Screen Shot 2015-09-11 at 2.40.52 PM.png
1 comment
Comment actions Permalink

For the record, disabling "ide.mac.message.dialogs.as.sheets" in Applications/IntelliJ IDEA 13/bin/idea.properties per this suggestion seems to have solved the issue.

-Aaron

0

Please sign in to leave a comment.