Fix idea.properties override on Mac... please?

I'm hoping to lobby for IDEA-100680...

On Mac OS X the idea.properties override mechanism doesn't work because of some typo somewhere in the idea source where IDEA looks for "idea.properites" (see the typo) instead of the proper filename. (The bug above has all the details.)

This stack overflow (answered by JetBrains' CrazyCoder):
http://stackoverflow.com/questions/13578062/how-to-increase-ide-memory-limit-in-intellij-idea-on-mac
has plenty of comments showing that indeed it's broken for peeps for idea.properties.

The bug is so trivial it appears to have been fixed already, but it never got included in an EAP so far.. and with 12.1RC1 out, I'm really hoping to get it included before we have to wait to 13.

Pretty please? With sugar on top? :-)

Thanks

  vince.

5 comments

It seems 12.1 does read the right file. I have both idea.properties and idea.properites in ~/Library/Preferences/IntelliJIdea12/ and the last-read time on idea.properties corresponds with the latest launch.

However, It does not seem that my heap allocation parameters are having any effect. This is the contents of ~/Library/Preferences/IntelliJIdea12/idea.properties:

-Xms640m
-Xmx2048m
-XX:MaxPermSize=350m
-XX:ReservedCodeCacheSize=64m
-XX:+UseCodeCacheFlushing
-XX:+UseCompressedOops


The initial heap size does not correspond to the 640m I set nor does the heap expand beyond the 770m I'm accustomed to seeing even though I open several large projects and work for some time.

I also see the spinning beachball quite a bit, and I'd really like to reduce that.

Am I using idea.poroperties correctly?

0

These VM options belong to the idea.vmoptions file which can be overridden the same way (and that override has been working all along :) ). Check out the <app>/bin/idea.vmoptions file for an example.

0

That did it!

Thanks for enlightening me.

0

Please sign in to leave a comment.