Leda RC OS-X 10.8 issues

I tried Leda RC with JDK 7 under OS-X 10.8 by (by setting the Java version in Info.plist to 1.7*):

- the splash screen really splashes (disappears after a short flicker)

- when I compile a 4.6 Flex project, I get an error message:
  This Java instance does not support a 32-bit JVM.

The Oracle JDK 7 only comes in a 64-bit version. Is there a workaround or am I stuck with JDK 6 for Flex development?

The new UI looks cool, especially the Darcula theme. Looking forward to the release.

Thanks and regards,
Peter

5 comments
Comment actions Permalink

Please post these specific issues to YouTrack.

Also see http://youtrack.jetbrains.com/issue/IDEA-87919 for general state of JDK7 support on Mac.

0
Comment actions Permalink

The compiler is started with the "-d32" flag:


Starting Flex compiler:
/Library/Java/JavaVirtualMachines/jdk1.7.0_09.jdk/Contents/Home/jre/bin/java -d32 -Dapplication.home=/Users/Shared/FlexSDKs/4.6.b.23201 -Xmx384m -Dsun.io.useCanonCaches=false -Dfile.encoding=UTF-8 -Djava.awt.headless=true -Duser.language=en -Duser.region=en -Xmx512m -classpath "/Applications/Apps/IntelliJ IDEA 12.app/plugins/flex/lib/idea-flex-compiler-fix.jar:/Applications/Apps/IntelliJ IDEA 12.app/plugins/flex/lib/flex-compiler.jar:/Users/Shared/FlexSDKs/4.6.b.23201/lib/flex-compiler-oem.jar" com.intellij.flex.compiler.FlexCompiler 49244



Maybe under OS-X we need a -d32 switch to differentiate between JDK 6 and JDK 7 when starting the Flex compiler?

Thanks and regards,
Peter
0
Comment actions Permalink

By default Flex compiler is started with the same java that is used for IntelliJ IDEA startup. But this can be overridden in <Flex SDK>/bin/jvm.config file (java.home property). So you can continue running IDE under java 7 at your own risk, but for Flex looks like you need to use 32-bit compatible java 6. When IntelliJ IDEA switches to java 7 by default we'll fix the problem with Flex compiler startup.

0
Comment actions Permalink

Hi Alex,

I am using the <Flex SDK>/bin/jvm.config option - it works fine.

Thanks and regards,
Peter

0
Comment actions Permalink

For those of us using flex-mojos there is no <Flex SDK>/bin/jvm.config folder.

I was able to work around this within IDEA by simply adding -d64 to the VM Options of:


Settings -> Compiler -> Flex Compiler -> VM Options

The -d32 flag still shows up but turns out that a following -d64 cancels it out.



Platform: OSX, Leda 123.111, Oracle JDK 7.

Now my flex app can compile and run.
0

Please sign in to leave a comment.