Please help, Leda - After power fall, I can no longer compile:

Got this exception:

EXTERNAL BUILD: Error: unexpected element: [Element: <Form/>]
com.intellij.uiDesigner.compiler.UnexpectedFormElementException: unexpected element: [Element: <Form/>]
    at com.intellij.uiDesigner.lw.LwRootContainer.read(LwRootContainer.java:60)
    at com.intellij.uiDesigner.compiler.Utils.getRootContainerFromDocument(Utils.java:100)
    at com.intellij.uiDesigner.compiler.Utils.getRootContainer(Utils.java:86)
    at org.jetbrains.jps.incremental.java.JavaBuilder.instrumentForms(JavaBuilder.java:977)
    at org.jetbrains.jps.incremental.java.JavaBuilder.compile(JavaBuilder.java:377)
    at org.jetbrains.jps.incremental.java.JavaBuilder.build(JavaBuilder.java:266)
    at org.jetbrains.jps.incremental.IncProjectBuilder.runModuleLevelBuilders(IncProjectBuilder.java:761)
    at org.jetbrains.jps.incremental.IncProjectBuilder.runBuildersForChunk(IncProjectBuilder.java:528)
    at org.jetbrains.jps.incremental.IncProjectBuilder.buildTargetsChunk(IncProjectBuilder.java:557)
    at org.jetbrains.jps.incremental.IncProjectBuilder.buildChunkIfAffected(IncProjectBuilder.java:491)
    at org.jetbrains.jps.incremental.IncProjectBuilder.access$200(IncProjectBuilder.java:59)
    at org.jetbrains.jps.incremental.IncProjectBuilder$3.run(IncProjectBuilder.java:428)
    at java.util.concurrent.Executors$RunnableAdapter.call(Executors.java:471)
    at java.util.concurrent.FutureTask$Sync.innerRun(FutureTask.java:334)
    at java.util.concurrent.FutureTask.run(FutureTask.java:166)
    at com.intellij.util.concurrency.BoundedTaskExecutor$1.run(BoundedTaskExecutor.java:35)
    at org.jetbrains.jps.service.impl.SharedThreadPoolImpl$1.run(SharedThreadPoolImpl.java:26)
    at java.util.concurrent.Executors$RunnableAdapter.call(Executors.java:471)
    at java.util.concurrent.FutureTask$Sync.innerRun(FutureTask.java:334)
    at java.util.concurrent.FutureTask.run(FutureTask.java:166)
    at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1110)
    at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:603)
    at java.lang.Thread.run(Thread.java:722)

14 comments
Comment actions Permalink

I reinstall IntelliJ
Deleted config directory
Create new copy of project from VC

Nothing help

0
Comment actions Permalink

Invalidate caches

0
Comment actions Permalink

Thanks.
I deleted system folder -still no luck

0
Comment actions Permalink

Are you sure that *.form files are valid, e.g. the same content is successfully compiled for other team members?
Will it help if you switch off 'Use external build' at Settings | Compiler?

0
Comment actions Permalink

Thank for reply - I'm really lost here.

The sources are compiled succesfuly by other memebres, more than that on my desktop same source is compile dby IntelliJ 11.

The last thing I'm trying is too look under ~ - maybe there are settings that some third party keep there. For example I found  ~/.yjp that have some was creadt by IntelliJ.
I deleted it - still no luck.
It  is my thid day on it.

I will glad for any tip.

B.R
Boaz

0
Comment actions Permalink

Can you help me turn compiler log - maybe it will help locate the file ?

0
Comment actions Permalink

Did you try to switch off external build?

0
Comment actions Permalink

Yes it is the default in ou project.
But now I see the parallel is on. I will try without it.

0
Comment actions Permalink

Your error happened with external build enabled. I asked if the error is the same if you disable it.

0
Comment actions Permalink

No luck.

EXTERNAL BUILD: Error: unexpected element: [Element: <Form/>]
com.intellij.uiDesigner.compiler.UnexpectedFormElementException: unexpected element: [Element: <Form/>]
    at com.intellij.uiDesigner.lw.LwRootContainer.read(LwRootContainer.java:60)
    at com.intellij.uiDesigner.compiler.Utils.getRootContainerFromDocument(Utils.java:100)
    at com.intellij.uiDesigner.compiler.Utils.getRootContainer(Utils.java:86)
    at org.jetbrains.jps.incremental.java.JavaBuilder.instrumentForms(JavaBuilder.java:977)
    at org.jetbrains.jps.incremental.java.JavaBuilder.compile(JavaBuilder.java:377)
    at org.jetbrains.jps.incremental.java.JavaBuilder.build(JavaBuilder.java:266)
    at org.jetbrains.jps.incremental.IncProjectBuilder.runModuleLevelBuilders(IncProjectBuilder.java:761)
    at org.jetbrains.jps.incremental.IncProjectBuilder.runBuildersForChunk(IncProjectBuilder.java:528)
    at org.jetbrains.jps.incremental.IncProjectBuilder.buildTargetsChunk(IncProjectBuilder.java:557)
    at org.jetbrains.jps.incremental.IncProjectBuilder.buildChunkIfAffected(IncProjectBuilder.java:491)
    at org.jetbrains.jps.incremental.IncProjectBuilder.buildChunks(IncProjectBuilder.java:474)
    at org.jetbrains.jps.incremental.IncProjectBuilder.runBuild(IncProjectBuilder.java:229)
    at org.jetbrains.jps.incremental.IncProjectBuilder.build(IncProjectBuilder.java:124)
    at org.jetbrains.jps.cmdline.BuildRunner.runBuild(BuildRunner.java:114)
    at org.jetbrains.jps.cmdline.BuildSession.runBuild(BuildSession.java:188)
    at org.jetbrains.jps.cmdline.BuildSession.run(BuildSession.java:93)
    at org.jetbrains.jps.cmdline.BuildMain$MyMessageHandler$1.run(BuildMain.java:105)
    at org.jetbrains.jps.service.impl.SharedThreadPoolImpl$1.run(SharedThreadPoolImpl.java:26)
    at java.util.concurrent.Executors$RunnableAdapter.call(Executors.java:471)
    at java.util.concurrent.FutureTask$Sync.innerRun(FutureTask.java:334)
    at java.util.concurrent.FutureTask.run(FutureTask.java:166)
    at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1110)
    at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:603)
    at java.lang.Thread.run(Thread.java:722)

0
Comment actions Permalink

Looks like the issue was fixed yesterday. The fix will be available in the next EAP, today or tomorrow.

0
Comment actions Permalink

Sorry didn't read your instruction carefully.
Indeed switching it off solve the problem - but I don't understand it was always on !
Maybe I didn't perfom full build since I  last upgraded.

And you are right agin, indeed it is the same issue http://youtrack.jetbrains.com/issue/IDEA-94205 (old forms created by netbeans)

Thanks for you help
Boaz

0
Comment actions Permalink

The error happens because IntelliJ IDEA is confised with *.form files that are not IntelliJ IDEA UI forms. Probably these are *.form files from Netbeans. As I already said - the issue is fixed and the fix will be available in the next EAP.
But there's a very simple workaround for you: as I said twice - uncheck 'Use external build' check box. But you still try to compile with 'Use external build' checked.

0
Comment actions Permalink

The option became enabled by default only in the latest EAP - that's why you faced the issue.

0

Please sign in to leave a comment.