Update 117.622 to 117.721 fails

There is an exception:

java.util.zip.ZipException: ZIP file must have at least one entry
     at java.util.zip.ZipOutputStream.finish(ZipOutputStream.java:304)
     at java.util.zip.DeflaterOutputStream.close(DeflaterOutputStream.java:140)
     at java.util.zip.ZipOutputStream.close(ZipOutputStream.java:321)
     at com.intellij.updater.ZipOutputWrapper.close(ZipOutputWrapper.java:140)
     at com.intellij.updater.UpdateZipAction.doApply(UpdateZipAction.java:178)
     at com.intellij.updater.PatchAction.apply(PatchAction.java:138)
     at com.intellij.updater.Patch$3.forEach(Patch.java:194)
     at com.intellij.updater.Patch.forEach(Patch.java:239)
     at com.intellij.updater.Patch.apply(Patch.java:190)
     at com.intellij.updater.PatchFileCreator.apply(PatchFileCreator.java:75)
     at com.intellij.updater.PatchFileCreator.apply(PatchFileCreator.java:66)
     at com.intellij.updater.Runner.doInstall(Runner.java:192)
     at com.intellij.updater.Runner.access$000(Runner.java:13)
     at com.intellij.updater.Runner$1.execute(Runner.java:159)
     at com.intellij.updater.SwingUpdaterUI$5.run(SwingUpdaterUI.java:186)
     at java.lang.Thread.run(Thread.java:680)

2 comments
Comment actions Permalink

Just to add to @Donald's post, I am also hitting the same error on my mac.

I am able to successfully upgrade on a windows box (windows 7), but hit this same error on my mac (running Lion - v. 10.7.4).

Hope that helps.

0

Please sign in to leave a comment.