How to connect IDEA to a remote Drupal instance?

Hi all,

I'm trying to replicate the PhpStorm 'Create New Project from Existing Files' in IDEA Ultimate 14.1.4, but I'm failing. Could someone give me some guidance?

4 comments
Comment actions Permalink

I apologize for the multiple posts. Moderators, please delete this extraneous posting.

Thanks!

0
Comment actions Permalink

Apologies, but it seems the wrong post was removed. :)

I'm trying to replicate the PhpStorm 'New Project from Existing Files' behavior in IDEA, but failing. I have a "remote" Drupal instance running on a vagrant VM. I would like to synchronize/index the files in a project locally, but I have something misconfigured, or I'm missing a step. To be clear, the files *start* on the VM and I would like to make them a project on my local file system. Could someone give me some guidance?

I have the following under Files > Settings:
* Plugins:
     * Drupal Support
     * PHP
     * PHP Remote Interpreter
     * Remote Hosts Access
* Build, Execution, Deployment > Deployment:
     * a working SFTP connection to my VM
* Languages & Frameworks > PHP:
     * PHP language level is set to 5.6
     * Interpreter is set to a working SSH-based connection to my VM
* Languages & Frameworks > PHP > Drupal:
     * Integration is enabled
     * Drupal install path is set to the path on the VM (/var/www/drupal)
     * Set up PHP | Include paths is checked
     * Drupal version 7

I'm positive I am missing some step, but I'm not sure what it is. When I try to File > New > and select any of the options, I'm never able to get the path to the VM's drupal files.
Thank you very much for your time and trouble.

0
Comment actions Permalink

Make sure the deployment server configuration is set as default. You may also want to enable automatic upload so that when you save the file, it's uploaded to the remote.

Verify that the mappings are configured correctly so that the files are uploaded to the desired remote folder.

1
Comment actions Permalink

Hi Serge,

Thank you for the response. It turns out I had the 'Deployment path on server...' mapped incorrectly.
Much appreciate the help!

Cheers,
Bridger

0

Please sign in to leave a comment.