How do I change cursor from a block back to | ?

Answered

On my Mac, somehow, the caret indicating the typing position changed from | to a black filled rectangle. How do I get the

     |

caret back?

27 comments
Comment actions Permalink

If you have Vim installed, make sure that Vim Emulator mode is off (Alt+Cmd+V on Mac)

23
Comment actions Permalink

FWIW, I had this problem recently on a new install of IntelliJ. I installed the IdeaVim plugin, thinking it was something else. The reason I had the block instead of the cursor was because the editor was in vim's View Mode as opposed to Insert Mode. In my case, I simply deactivated the plugin by going to Preferences -> Plugins, unchecking IdeaVim and restarting.

11
Comment actions Permalink

Block cursor indicates Insert mode. You can toggle it with Insert key.

Another possible reason is Block caret option enabled:

http://i.imgur.com/RKxIvHR.png

9
Comment actions Permalink

Hi Paul,

Have you looked under File > Settings > Editor > General > Appearance?
There is a check box for 'Use block caret' - maybe yours is checked?

HTH.

7
Comment actions Permalink

⌥ + ⌘ +  v 

5
Comment actions Permalink

Go to Tools and unclick Vim Emulator and insert and ctrl+c, ... problems go away.

4
Comment actions Permalink

Insert key.

If you don't know which one, remap it here and hit it to toggle this mode:

http://i.imgur.com/Edzm4EW.png

3
Comment actions Permalink

On my Mac keyboard toggle shortcut is: Fn+Enter.

Hope it helps, guys.

2
Comment actions Permalink

Thanks for the help guys!

I am on Mac, and this is in Android Studio. I never enabled the block cursor--it magically appeard when I accidentally typed some keyboard combination.

Any idea what key combination that might have been?

1
Comment actions Permalink

How do you change the terminal block through a pipeline?

1
Comment actions Permalink

Had this happen on a Mac while connected to a Windows machine via Remote Desktop, somehow while attempting to type open and closed curly braces (both of which typed). I couldn't find any solution to trigger it back, from attempting to finger-fumble re-discover the initial trigger, to all the suggestions here and some other sites. Nothing acted like Insert (including the ubiquitous clear+0 on the keypad).

Luckily, Insert mode is set per file (at least in my case), so closing and re-opening the file was an easy fix.

More importantly, I cleared the Insert/Overwrite shortcut from all my installations because I will never want that.

 

1
Comment actions Permalink

fn + ins(prt sc)  it gives back | .

1
Comment actions Permalink

Search "print screen" button on your keyboard and press it...
It worked for me coz "insert" and "print screen" are same button in my keyboard....

1
Comment actions Permalink

There's no 'INS' key on the Mac keyboard, so I was lost as to how this was happening. Then someone mentioned that it occurred when opening every new file which was the same as my scenario. Unchecking the Vim Emulator did the trick for me!

Thanks @Sdfor.

1
Comment actions Permalink

I have this very annoying problem: every time I open my python project, the cursor is in the caret mode... The "Use block caret" is switched off. I've tried to select the checkbox and then unselect it. Doesn't help. Please, help!

The version of the PyCharm:
PyCharm 2019.1.1 (Community Edition)
Build #PC-191.6605.12, built on April 3, 2019
JRE: 11.0.2+9-b159.34 x86_64
JVM: OpenJDK 64-Bit Server VM by JetBrains s.r.o
macOS 10.14.4

My laptop:
MacBook Pro (13-inch, 2017, Two Thunderbolt 3 ports)
macOS 10.14.4 (18E226)

1
Comment actions Permalink

On a Mac there is no short cut to Enable or Disable the Insert mode. 

Just go to the Keymap section of preferences and add a Keyboard Shortcut for yourself to Toggle between the Instert/Overwrite cursor mode.

 

0
Comment actions Permalink

@NibragWeb you can't. According to https://www.jetbrains.com/help/idea/working-with-embedded-local-terminal.html#d899716e37

"Note that the setting Use block caret is not inherited in the terminal - its caret is always block."

0
Comment actions Permalink

it is weird on mac when i open any file cursor indicates is Insert mode.

i need to switch in every file i opened.

and i can't type anything without switching several times.

And block caret option is not click.

.

sorry for my bad english.

 

0
Comment actions Permalink

Serge, thank you so much!! I've missed the comment about Vim.

0
Comment actions Permalink

I just encounter a similar problem and was confused. I noticed that the cursor changed because I pressed a certain key on my keyboard mistakenly. I pressed numeric key 0 and the cursor went back to normal

0
Comment actions Permalink

Serge your my hero i'm doing courses and was so close to giving up learning because this was stressing me out and ruining my code when i was looking away while typing following the instructor.... <3

0
Comment actions Permalink

I unchecked the Column Selection Mode option under the Edit menu in my case.

0
Comment actions Permalink

actvitymain de oluşturduğum editText i java class a nasıl işlerim ?

kendi oluşturduğum imleci nasıl kullanırım?(selam)

-1
Comment actions Permalink

@Josh Cummings this works perfect for me: "Preferences -> Plugins, unchecking IdeaVim and restarting"

 

thanks.

-1
Comment actions Permalink

bu tür yerlerde soruna çözüm bulamadığım için genelde bu tür yerlere başvuru yapmam. bi deneyim dedim ve tecrübem beni haklı çıkardı. sahipsiz kimsesiz başıboş liyakatsiz konumda bir site. kıytırıktan bir site.

-1

Please sign in to leave a comment.