Jboss 7 remote debug

Hi,

I'm trying to connect to a JBoss with the remote debug profile, but for some reason I cannot seem to get it to work.

The debug parameters as stated in the debug connection are using port 60376 with a socket connection. I start the jbos 7.1 server and see the line: Listening for transport dt_socket at address: 60376. So this seems to be correct.
When trying to run the debug configuration I get the error: ' Error running JBoss 7: Unable to connect to the 127.0.0.1:8080'. These are the 'remote connection settings' that are set on the first tab. For one, I don't see why these parameters are used to connect. These parameters seem to related to opening the start page in a browser (when changing these settings the url changes as well). I thought only the debug port would be necessary, why do I even need that remote parameter section? And why can't I connect if I fill these in to the correct http location? My server is available at localhost:8080, the default suggestion of remote parameter settings is exactly that, but it doesn't work.  Am I missing something? (I'm at the point where I feel completely retarded....)

When using the JBoss local profile, everything seems to be OK.

Using EAP 117.47 on Ubuntu 11.10 with JBoss 7.1.0-final.

Kind Regards.

2 comments
Comment actions Permalink

IDEA requires 2 ports to be specified in the JBoss remote run configuration (in addition to debug port in debug mode):

1) http port ('Port' field of the 'Remote Connection Settings' section) is used to ping JBoss server (periodical checking if the
server is alive) and to produce urls addressing resources on the server

2) native management port ('Management port' field of the 'JBoss Server Settings' section) is used to connect to the JBoss managenent
interface, to check for the server startup to be finished and to deploy artifacts

It looks like you have wrong native management port setting -- since you state you have correct http port. The error message is expected to
contain http port number in this case.

If you don't know your management port setting, you may look up it in the file <JBoss home>/standalone/configuration/standalone.xml under

the XPath /socket-binding-group/socket-binding[@name='management-native']/@port.


IDEA initialized the newly created JBoss remote run configuration with the default setting value of 9999.


Regards,
Michael
0
Comment actions Permalink

Thanks,

The port was indeed not the native port of JBoss. It was kinda confusing for me as there are three ports listed in the jboss config, http, https and native., for some reason I kept thinking that port was right.... stupid, I know... Perhaps it would help other hard-headed people if the label just states 'Native Management Port' instead....

Kind Regards,
Jan

0

Please sign in to leave a comment.