6 comments
Comment actions Permalink

The Ruby plugin for the previous EAP is already available. It's likely that we'll publish a new update for the latest EAP this week. For La Clojure, I can't give any ETA; you may need to wait until the final 11.1 release.

0
Comment actions Permalink

Hello, I'm trying to install the La Clojure plugin Vesrion Version: 0.7.83  on RubyMine 2016.2.2 and I'm getting this error after restart:

 

Plugin 'org.intellij.clojure' failed to initialize and will be disabled.  Please restart RubyMine.

 

java.lang.NoClassDefFoundError: clojure/lang/Var

    at org.jetbrains.plugins.clojure.ClojureLoader.initComponent(ClojureLoader.java:42)

    at com.intellij.openapi.components.impl.ComponentManagerImpl$ComponentConfigComponentAdapter.getComponentInstance(ComponentManagerImpl.java:518)

    at com.intellij.openapi.components.impl.ComponentManagerImpl.createComponents(ComponentManagerImpl.java:119)

    at com.intellij.openapi.application.impl.ApplicationImpl.a(ApplicationImpl.java:430)

    at com.intellij.openapi.progress.impl.CoreProgressManager$3.run(CoreProgressManager.java:170)

    at com.intellij.openapi.progress.impl.CoreProgressManager.registerIndicatorAndRun(CoreProgressManager.java:494)

    at com.intellij.openapi.progress.impl.CoreProgressManager.executeProcessUnderProgress(CoreProgressManager.java:443)

    at com.intellij.openapi.progress.impl.ProgressManagerImpl.executeProcessUnderProgress(ProgressManagerImpl.java:54)

    at com.intellij.openapi.progress.impl.CoreProgressManager.runProcess(CoreProgressManager.java:155)

    at com.intellij.openapi.application.impl.ApplicationImpl.createComponents(ApplicationImpl.java:443)

    at com.intellij.openapi.components.impl.ComponentManagerImpl.init(ComponentManagerImpl.java:103)

    at com.intellij.openapi.application.impl.ApplicationImpl.load(ApplicationImpl.java:393)

    at com.intellij.openapi.application.impl.ApplicationImpl.load(ApplicationImpl.java:385)

    at com.intellij.idea.IdeaApplication.run(IdeaApplication.java:193)

    at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)

    at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:62)

    at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)

    at java.lang.reflect.Method.invoke(Method.java:498)

    at com.intellij.idea.MainImpl$1$1.a(MainImpl.java:62)

    at java.awt.event.InvocationEvent.dispatch(InvocationEvent.java:311)

    at java.awt.EventQueue.dispatchEventImpl(EventQueue.java:756)

    at java.awt.EventQueue.access$500(EventQueue.java:97)

    at java.awt.EventQueue$3.run(EventQueue.java:709)

    at java.awt.EventQueue$3.run(EventQueue.java:703)

    at java.security.AccessController.doPrivileged(Native Method)

    at java.security.ProtectionDomain$JavaSecurityAccessImpl.doIntersectionPrivilege(ProtectionDomain.java:76)

    at java.awt.EventQueue.dispatchEvent(EventQueue.java:726)

    at com.intellij.ide.IdeEventQueue.dispatchEvent(IdeEventQueue.java:358)

    at java.awt.EventDispatchThread.pumpOneEventForFilters(EventDispatchThread.java:201)

    at java.awt.EventDispatchThread.pumpEventsForFilter(EventDispatchThread.java:116)

    at java.awt.EventDispatchThread.pumpEventsForHierarchy(EventDispatchThread.java:105)

    at java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:101)

    at java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:93)

    at java.awt.EventDispatchThread.run(EventDispatchThread.java:82)

Caused by: java.lang.ClassNotFoundException: clojure.lang.Var PluginClassLoader[org.intellij.clojure, 0.7.83]

    at com.intellij.ide.plugins.cl.PluginClassLoader.loadClass(PluginClassLoader.java:64)

    at java.lang.ClassLoader.loadClass(ClassLoader.java:357)

0
Comment actions Permalink

La Clojure plugin is no longer maintained. Please use Cursive (https://cursive-ide.com/) instead.

0
Comment actions Permalink

There is no option for RubyMine only InteliJ am I missing something?

0
Comment actions Permalink

No. We do not offer any supported solution for developing Clojure in RubyMine; please use the free IntelliJ IDEA Community Edition instead.

0
Comment actions Permalink

Check out Clojure-Kit https://plugins.jetbrains.com/plugin/8636

Should work on any IntelliJ-based IDE ver. 2016.2.3 and up.

0

Please sign in to leave a comment.