how to disable zoom in/out of text (code) when using apple Gestures

This is a trivial yet annoying issue: I use a mac. While developing, my left thumb is always on Cmd key (as most inspections are invoked on Cmd+<some key or click>). But in conjunction with an apple magic mouse or the trackpad, the gesture of two fingers moving is interpreted as zoom, and so IntelliJ immediately changes ALL the font up/down.

This is annoying and I haven't found a way to disable this. I've also disabled all gestures from Apple's System Preferences but this problem continues hinting that it's an intelliJ issue.

Thanks

2 comments
Comment actions Permalink

Hello infinity,

The top left checkbox in Settings | Editor is the one that you need.

This is a trivial yet annoying issue: I use a mac. While developing,
my left thumb is always on Cmd key (as most inspections are invoked on
Cmd+<some key or click>). But in conjunction with an apple magic mouse
or the trackpad, the gesture of two fingers moving is interpreted as
zoom, and so IntelliJ immediately changes ALL the font up/down.

This is annoying and I haven't found a way to disable this. I've also
disabled all gestures from Apple's System Preferences but this problem
continues hinting that it's an intelliJ issue.


--
Dmitry Jemerov
Development Lead
JetBrains, Inc.
http://www.jetbrains.com/
"Develop with Pleasure!"


0
Comment actions Permalink

PERFECT.

Thanks!

0

Please sign in to leave a comment.